diff options
author | Colin Watson <cjwatson@debian.org> | 2010-04-08 09:25:21 +0100 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2010-04-08 09:25:21 +0100 |
commit | 4b9dad928332455162b0257d72b33554fdb799fc (patch) | |
tree | ceeca3b7acb4e3a300d1aba06313454b96916500 /debian | |
parent | 8ce3a1fcd48d46696ff88bc7297b75cb4838791c (diff) |
Use dh_install more effectively.
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 1 | ||||
-rw-r--r-- | debian/openssh-client-udeb.install | 3 | ||||
-rw-r--r-- | debian/openssh-client.install | 27 | ||||
-rw-r--r-- | debian/openssh-server-udeb.install | 2 | ||||
-rw-r--r-- | debian/openssh-server.install | 6 | ||||
-rwxr-xr-x | debian/rules | 22 |
6 files changed, 45 insertions, 16 deletions
diff --git a/debian/changelog b/debian/changelog index 56c3b5bbe..e271bb5a1 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -6,6 +6,7 @@ openssh (1:5.4p1-2) UNRELEASED; urgency=low | |||
6 | verification (closes: #572049). | 6 | verification (closes: #572049). |
7 | * Convert to dh(1), and use dh_installdocs --link-doc. | 7 | * Convert to dh(1), and use dh_installdocs --link-doc. |
8 | * Drop lpia support, since Ubuntu no longer supports this architecture. | 8 | * Drop lpia support, since Ubuntu no longer supports this architecture. |
9 | * Use dh_install more effectively. | ||
9 | 10 | ||
10 | -- Colin Watson <cjwatson@debian.org> Tue, 06 Apr 2010 23:16:39 +0100 | 11 | -- Colin Watson <cjwatson@debian.org> Tue, 06 Apr 2010 23:16:39 +0100 |
11 | 12 | ||
diff --git a/debian/openssh-client-udeb.install b/debian/openssh-client-udeb.install new file mode 100644 index 000000000..b3891f02d --- /dev/null +++ b/debian/openssh-client-udeb.install | |||
@@ -0,0 +1,3 @@ | |||
1 | scp usr/bin | ||
2 | sftp usr/bin | ||
3 | ssh usr/bin | ||
diff --git a/debian/openssh-client.install b/debian/openssh-client.install index aadaaf288..fd9e8feab 100644 --- a/debian/openssh-client.install +++ b/debian/openssh-client.install | |||
@@ -1,2 +1,29 @@ | |||
1 | etc/ssh/moduli | ||
2 | etc/ssh/ssh_config | ||
3 | usr/bin/scp | ||
4 | usr/bin/sftp | ||
5 | usr/bin/slogin | ||
6 | usr/bin/ssh | ||
7 | usr/bin/ssh-add | ||
8 | usr/bin/ssh-agent | ||
9 | usr/bin/ssh-keygen | ||
10 | usr/bin/ssh-keyscan | ||
11 | usr/bin/ssh-vulnkey | ||
12 | usr/lib/openssh/ssh-keysign | ||
13 | usr/lib/openssh/ssh-pkcs11-helper | ||
14 | usr/share/man/man1/scp.1 | ||
15 | usr/share/man/man1/sftp.1 | ||
16 | usr/share/man/man1/slogin.1 | ||
17 | usr/share/man/man1/ssh-add.1 | ||
18 | usr/share/man/man1/ssh-agent.1 | ||
19 | usr/share/man/man1/ssh-keygen.1 | ||
20 | usr/share/man/man1/ssh-keyscan.1 | ||
21 | usr/share/man/man1/ssh-vulnkey.1 | ||
22 | usr/share/man/man1/ssh.1 | ||
23 | usr/share/man/man5/moduli.5 | ||
24 | usr/share/man/man5/ssh_config.5 | ||
25 | usr/share/man/man8/ssh-keysign.8 | ||
26 | usr/share/man/man8/ssh-pkcs11-helper.8 | ||
27 | |||
1 | contrib/ssh-copy-id usr/bin | 28 | contrib/ssh-copy-id usr/bin |
2 | debian/ssh-argv0 usr/bin | 29 | debian/ssh-argv0 usr/bin |
diff --git a/debian/openssh-server-udeb.install b/debian/openssh-server-udeb.install new file mode 100644 index 000000000..05ccbf7af --- /dev/null +++ b/debian/openssh-server-udeb.install | |||
@@ -0,0 +1,2 @@ | |||
1 | sshd usr/sbin | ||
2 | ssh-keygen usr/bin | ||
diff --git a/debian/openssh-server.install b/debian/openssh-server.install new file mode 100644 index 000000000..8e04c4170 --- /dev/null +++ b/debian/openssh-server.install | |||
@@ -0,0 +1,6 @@ | |||
1 | usr/lib/openssh/sftp-server | ||
2 | usr/sbin/sshd | ||
3 | usr/share/man/man5/authorized_keys.5 | ||
4 | usr/share/man/man5/sshd_config.5 | ||
5 | usr/share/man/man8/sftp-server.8 | ||
6 | usr/share/man/man8/sshd.8 | ||
diff --git a/debian/rules b/debian/rules index f2c24ddf9..85b916bd4 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -151,30 +151,20 @@ endif | |||
151 | > debian/copyright | 151 | > debian/copyright |
152 | 152 | ||
153 | override_dh_auto_install: | 153 | override_dh_auto_install: |
154 | $(MAKE) -C build-deb DESTDIR=`pwd`/debian/openssh-client install-nokeys | 154 | $(MAKE) -C build-deb DESTDIR=`pwd`/debian/tmp install-nokeys |
155 | 155 | ||
156 | rm -f debian/openssh-client/etc/ssh/sshd_config | 156 | override_dh_install: |
157 | rm -f debian/tmp/etc/ssh/sshd_config | ||
157 | 158 | ||
158 | # Split off the server. | 159 | dh_install -Nopenssh-client-udeb -Nopenssh-server-udeb --fail-missing |
159 | mv debian/openssh-client/usr/sbin/sshd debian/openssh-server/usr/sbin/ | 160 | dh_install -popenssh-client-udeb -popenssh-server-udeb \ |
160 | mv debian/openssh-client/usr/lib/openssh/sftp-server debian/openssh-server/usr/lib/openssh/ | 161 | --sourcedir=build-udeb |
161 | mv debian/openssh-client/usr/share/man/man5/authorized_keys.5 debian/openssh-server/usr/share/man/man5/ | ||
162 | mv debian/openssh-client/usr/share/man/man5/sshd_config.5 debian/openssh-server/usr/share/man/man5/ | ||
163 | mv debian/openssh-client/usr/share/man/man8/sshd.8 debian/openssh-server/usr/share/man/man8/ | ||
164 | mv debian/openssh-client/usr/share/man/man8/sftp-server.8 debian/openssh-server/usr/share/man/man8/ | ||
165 | rmdir debian/openssh-client/usr/sbin debian/openssh-client/var/run/sshd | ||
166 | 162 | ||
167 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass | 163 | install -s -o root -g root -m 755 contrib/gnome-ssh-askpass2 debian/ssh-askpass-gnome/usr/lib/openssh/gnome-ssh-askpass |
168 | 164 | ||
169 | install -o root -g root debian/openssh-server.if-up debian/openssh-server/etc/network/if-up.d/openssh-server | 165 | install -o root -g root debian/openssh-server.if-up debian/openssh-server/etc/network/if-up.d/openssh-server |
170 | install -o root -g root -m 644 debian/openssh-server.ufw.profile debian/openssh-server/etc/ufw/applications.d/openssh-server | 166 | install -o root -g root -m 644 debian/openssh-server.ufw.profile debian/openssh-server/etc/ufw/applications.d/openssh-server |
171 | 167 | ||
172 | install -m 755 build-udeb/ssh debian/openssh-client-udeb/usr/bin/ssh | ||
173 | install -m 755 build-udeb/scp debian/openssh-client-udeb/usr/bin/scp | ||
174 | install -m 755 build-udeb/sftp debian/openssh-client-udeb/usr/bin/sftp | ||
175 | install -m 755 build-udeb/sshd debian/openssh-server-udeb/usr/sbin/sshd | ||
176 | install -m 755 build-udeb/ssh-keygen debian/openssh-server-udeb/usr/bin/ssh-keygen | ||
177 | |||
178 | # Remove version control tags to avoid unnecessary conffile | 168 | # Remove version control tags to avoid unnecessary conffile |
179 | # resolution steps for administrators. | 169 | # resolution steps for administrators. |
180 | sed -i '/\$$OpenBSD:/d' \ | 170 | sed -i '/\$$OpenBSD:/d' \ |