diff options
author | Colin Watson <cjwatson@debian.org> | 2010-01-12 18:51:19 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2010-01-12 18:51:19 +0000 |
commit | 63f53e4f02ecb179aabb8ff55a531bf5ee76f8c5 (patch) | |
tree | f8a3250b35d7d872d61a55ac87d3553cf3afffc2 /debian | |
parent | 8d610ba26a3041f567441d7260f47425ef52012b (diff) |
Use host compiler for ssh-askpass-gnome when cross-compiling.
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 1 | ||||
-rwxr-xr-x | debian/rules | 4 |
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog index b8dde56ee..8d617adde 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -4,6 +4,7 @@ openssh (1:5.2p1-2) UNRELEASED; urgency=low | |||
4 | - After sshd receives a SIGHUP, ignore subsequent HUPs while sshd | 4 | - After sshd receives a SIGHUP, ignore subsequent HUPs while sshd |
5 | re-execs itself. Prevents two HUPs in quick succession from resulting | 5 | re-execs itself. Prevents two HUPs in quick succession from resulting |
6 | in sshd dying (LP: #497781). | 6 | in sshd dying (LP: #497781). |
7 | * Use host compiler for ssh-askpass-gnome when cross-compiling. | ||
7 | 8 | ||
8 | -- Colin Watson <cjwatson@debian.org> Sun, 10 Jan 2010 22:06:28 +0000 | 9 | -- Colin Watson <cjwatson@debian.org> Sun, 10 Jan 2010 22:06:28 +0000 |
9 | 10 | ||
diff --git a/debian/rules b/debian/rules index 0966a2e55..8bba8f95e 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -19,8 +19,10 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE) | |||
19 | 19 | ||
20 | ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE)) | 20 | ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE)) |
21 | confflags += --build=$(DEB_HOST_GNU_TYPE) | 21 | confflags += --build=$(DEB_HOST_GNU_TYPE) |
22 | CC := gcc | ||
22 | else | 23 | else |
23 | confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) | 24 | confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE) |
25 | CC := $(DEB_HOST_GNU_TYPE)-gcc | ||
24 | endif | 26 | endif |
25 | 27 | ||
26 | DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) | 28 | DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS 2>/dev/null) |
@@ -125,7 +127,7 @@ endif | |||
125 | perl -pi -e 's,.*#define USE_BTMP .*,/* #undef USE_BTMP */,' build-deb/config.h | 127 | perl -pi -e 's,.*#define USE_BTMP .*,/* #undef USE_BTMP */,' build-deb/config.h |
126 | 128 | ||
127 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' | 129 | $(MAKE) -C build-deb -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' |
128 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='gcc $(OPTFLAGS) -g -Wall' | 130 | $(MAKE) -C contrib gnome-ssh-askpass2 CC='$(CC) $(OPTFLAGS) -g -Wall' |
129 | $(MAKE) -C debian/tests | 131 | $(MAKE) -C debian/tests |
130 | 132 | ||
131 | touch build-deb-stamp | 133 | touch build-deb-stamp |