diff options
author | Colin Watson <cjwatson@debian.org> | 2017-06-06 15:02:28 +0100 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2017-06-06 15:03:25 +0100 |
commit | 6a6b1543715aaeeb9ddb07addf7e6b9049a431fb (patch) | |
tree | b73d4dc7b813b5cc534a2cf713d93f2cd0ad116b /debian | |
parent | af27669f905133925224acc753067dea710881dd (diff) | |
parent | a93e5207256eff3a51db335c5a12b3ad2291f686 (diff) |
Fix incoming compression statistics (thanks, Russell Coker; closes: #797964).
Diffstat (limited to 'debian')
-rw-r--r-- | debian/.git-dpm | 4 | ||||
-rw-r--r-- | debian/changelog | 7 | ||||
-rw-r--r-- | debian/patches/fix-incoming-compression-statistics.patch | 27 | ||||
-rw-r--r-- | debian/patches/series | 1 |
4 files changed, 37 insertions, 2 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm index 6c8df34b8..63d964cd3 100644 --- a/debian/.git-dpm +++ b/debian/.git-dpm | |||
@@ -1,6 +1,6 @@ | |||
1 | # see git-dpm(1) from git-dpm package | 1 | # see git-dpm(1) from git-dpm package |
2 | 904bc482ad87648a2c799c441dc6a8449f24e15a | 2 | a93e5207256eff3a51db335c5a12b3ad2291f686 |
3 | 904bc482ad87648a2c799c441dc6a8449f24e15a | 3 | a93e5207256eff3a51db335c5a12b3ad2291f686 |
4 | 971a7653746a6972b907dfe0ce139c06e4a6f482 | 4 | 971a7653746a6972b907dfe0ce139c06e4a6f482 |
5 | 971a7653746a6972b907dfe0ce139c06e4a6f482 | 5 | 971a7653746a6972b907dfe0ce139c06e4a6f482 |
6 | openssh_7.4p1.orig.tar.gz | 6 | openssh_7.4p1.orig.tar.gz |
diff --git a/debian/changelog b/debian/changelog index 7be0100c2..428eb30e9 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -1,3 +1,10 @@ | |||
1 | openssh (1:7.4p1-11) UNRELEASED; urgency=medium | ||
2 | |||
3 | * Fix incoming compression statistics (thanks, Russell Coker; closes: | ||
4 | #797964). | ||
5 | |||
6 | -- Colin Watson <cjwatson@debian.org> Tue, 06 Jun 2017 15:02:33 +0100 | ||
7 | |||
1 | openssh (1:7.4p1-10) unstable; urgency=medium | 8 | openssh (1:7.4p1-10) unstable; urgency=medium |
2 | 9 | ||
3 | * Move privilege separation directory and PID file from /var/run/ to /run/ | 10 | * Move privilege separation directory and PID file from /var/run/ to /run/ |
diff --git a/debian/patches/fix-incoming-compression-statistics.patch b/debian/patches/fix-incoming-compression-statistics.patch new file mode 100644 index 000000000..f503baa07 --- /dev/null +++ b/debian/patches/fix-incoming-compression-statistics.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From a93e5207256eff3a51db335c5a12b3ad2291f686 Mon Sep 17 00:00:00 2001 | ||
2 | From: Russell Coker <russell@coker.com.au> | ||
3 | Date: Tue, 6 Jun 2017 15:00:20 +0100 | ||
4 | Subject: Fix incoming compression statistics | ||
5 | |||
6 | Bug-Debian: https://bugs.debian.org/797964 | ||
7 | Forwarded: https://lists.mindrot.org/pipermail/openssh-unix-dev/2017-June/036077.html | ||
8 | Last-Update: 2017-06-06 | ||
9 | |||
10 | Patch-Name: fix-incoming-compression-statistics.patch | ||
11 | --- | ||
12 | packet.c | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/packet.c b/packet.c | ||
16 | index ad1f6b49..afcde6f3 100644 | ||
17 | --- a/packet.c | ||
18 | +++ b/packet.c | ||
19 | @@ -587,7 +587,7 @@ ssh_packet_close(struct ssh *ssh) | ||
20 | deflateEnd(stream); | ||
21 | } | ||
22 | if (state->compression_in_started) { | ||
23 | - z_streamp stream = &state->compression_out_stream; | ||
24 | + z_streamp stream = &state->compression_in_stream; | ||
25 | debug("compress incoming: " | ||
26 | "raw data %llu, compressed %llu, factor %.2f", | ||
27 | (unsigned long long)stream->total_out, | ||
diff --git a/debian/patches/series b/debian/patches/series index c5fc81486..7537fc157 100644 --- a/debian/patches/series +++ b/debian/patches/series | |||
@@ -34,3 +34,4 @@ ssh-keygen-hash-corruption.patch | |||
34 | ssh-keyscan-hash-port.patch | 34 | ssh-keyscan-hash-port.patch |
35 | ssh-keygen-null-deref.patch | 35 | ssh-keygen-null-deref.patch |
36 | unbreak-unix-forwarding-for-root.patch | 36 | unbreak-unix-forwarding-for-root.patch |
37 | fix-incoming-compression-statistics.patch | ||