diff options
author | Colin Watson <cjwatson@debian.org> | 2014-02-11 11:27:57 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2014-02-11 11:28:08 +0000 |
commit | b6e13bfac71554ebb32d1f293765cee5e9eabf63 (patch) | |
tree | 40a73eb469aa98f093d5c2bd0a615694c945de23 /debian | |
parent | 4be35c48f0c60c0c8badc76d3d69b5d1a57de8e1 (diff) | |
parent | c662cd7269217e67b4c47ed4afdbe0ca8d355fd4 (diff) |
Backport upstream patch to unbreak case-sensitive matching of ssh_config (closes: #738619).
Diffstat (limited to 'debian')
-rw-r--r-- | debian/.git-dpm | 4 | ||||
-rw-r--r-- | debian/changelog | 2 | ||||
-rw-r--r-- | debian/patches/fix-case-sensitive-matching.patch | 41 | ||||
-rw-r--r-- | debian/patches/series | 1 |
4 files changed, 46 insertions, 2 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm index 11c6ec01c..3455d7da0 100644 --- a/debian/.git-dpm +++ b/debian/.git-dpm | |||
@@ -1,6 +1,6 @@ | |||
1 | # see git-dpm(1) from git-dpm package | 1 | # see git-dpm(1) from git-dpm package |
2 | ee8d8b97cc2c6081df3af453a228992b87309ec4 | 2 | c662cd7269217e67b4c47ed4afdbe0ca8d355fd4 |
3 | ee8d8b97cc2c6081df3af453a228992b87309ec4 | 3 | c662cd7269217e67b4c47ed4afdbe0ca8d355fd4 |
4 | 9a975a9faed7c4f334e8c8490db3e77e102f2b21 | 4 | 9a975a9faed7c4f334e8c8490db3e77e102f2b21 |
5 | 9a975a9faed7c4f334e8c8490db3e77e102f2b21 | 5 | 9a975a9faed7c4f334e8c8490db3e77e102f2b21 |
6 | openssh_6.5p1.orig.tar.gz | 6 | openssh_6.5p1.orig.tar.gz |
diff --git a/debian/changelog b/debian/changelog index 9e821ff25..ba32acdc7 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -2,6 +2,8 @@ openssh (1:6.5p1-2) UNRELEASED; urgency=medium | |||
2 | 2 | ||
3 | * Only enable ssh.service for systemd, not both ssh.service and | 3 | * Only enable ssh.service for systemd, not both ssh.service and |
4 | ssh.socket. Thanks to Michael Biebl for spotting this. | 4 | ssh.socket. Thanks to Michael Biebl for spotting this. |
5 | * Backport upstream patch to unbreak case-sensitive matching of ssh_config | ||
6 | (closes: #738619). | ||
5 | 7 | ||
6 | -- Colin Watson <cjwatson@debian.org> Tue, 11 Feb 2014 10:41:26 +0000 | 8 | -- Colin Watson <cjwatson@debian.org> Tue, 11 Feb 2014 10:41:26 +0000 |
7 | 9 | ||
diff --git a/debian/patches/fix-case-sensitive-matching.patch b/debian/patches/fix-case-sensitive-matching.patch new file mode 100644 index 000000000..b6213962d --- /dev/null +++ b/debian/patches/fix-case-sensitive-matching.patch | |||
@@ -0,0 +1,41 @@ | |||
1 | From c662cd7269217e67b4c47ed4afdbe0ca8d355fd4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Damien Miller <djm@mindrot.org> | ||
3 | Date: Tue, 4 Feb 2014 11:26:04 +1100 | ||
4 | Subject: Unbreak case-sensitive matching of ssh_config | ||
5 | |||
6 | - djm@cvs.openbsd.org 2014/02/04 00:24:29 | ||
7 | [ssh.c] | ||
8 | delay lowercasing of hostname until right before hostname | ||
9 | canonicalisation to unbreak case-sensitive matching of ssh_config; | ||
10 | reported by Ike Devolder; ok markus@ | ||
11 | |||
12 | Origin: backport, https://anongit.mindrot.org/openssh.git/commit/?id=d56b44d2dfa093883a5c4e91be3f72d99946b170 | ||
13 | Bug-Debian: http://bugs.debian.org/738619 | ||
14 | Forwarded: not-needed | ||
15 | Last-Update: 2014-02-11 | ||
16 | |||
17 | Patch-Name: fix-case-sensitive-matching.patch | ||
18 | --- | ||
19 | ssh.c | 2 +- | ||
20 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/ssh.c b/ssh.c | ||
23 | index 0cea713..5d5d4de 100644 | ||
24 | --- a/ssh.c | ||
25 | +++ b/ssh.c | ||
26 | @@ -780,7 +780,6 @@ main(int ac, char **av) | ||
27 | if (!host) | ||
28 | usage(); | ||
29 | |||
30 | - lowercase(host); | ||
31 | host_arg = xstrdup(host); | ||
32 | |||
33 | OpenSSL_add_all_algorithms(); | ||
34 | @@ -914,6 +913,7 @@ main(int ac, char **av) | ||
35 | } | ||
36 | |||
37 | /* If canonicalization requested then try to apply it */ | ||
38 | + lowercase(host); | ||
39 | if (options.canonicalize_hostname != SSH_CANONICALISE_NO) | ||
40 | addrs = resolve_canonicalize(&host, options.port); | ||
41 | /* | ||
diff --git a/debian/patches/series b/debian/patches/series index 5d21e57d1..f571f76a5 100644 --- a/debian/patches/series +++ b/debian/patches/series | |||
@@ -26,3 +26,4 @@ no-openssl-version-check.patch | |||
26 | gnome-ssh-askpass2-icon.patch | 26 | gnome-ssh-askpass2-icon.patch |
27 | sigstop.patch | 27 | sigstop.patch |
28 | debian-config.patch | 28 | debian-config.patch |
29 | fix-case-sensitive-matching.patch | ||