diff options
author | Colin Watson <cjwatson@debian.org> | 2018-11-03 18:54:08 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2018-11-03 18:54:08 +0000 |
commit | be4c6dd37f7cd1fd6c9e7818a6392ce18fb3b585 (patch) | |
tree | 4b7770ce18fa5c26a84e77e4fb8b5c80b6a5d43e /debian | |
parent | c16684b54bdaa91df8db0869e69d1e55baa19053 (diff) |
Make the autopkgtest create /run/sshd if it doesn't already exist
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 1 | ||||
-rwxr-xr-x | debian/tests/regress | 13 |
2 files changed, 14 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog index 731fe17cc..9368bfee6 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -1,6 +1,7 @@ | |||
1 | openssh (1:7.9p1-2) UNRELEASED; urgency=medium | 1 | openssh (1:7.9p1-2) UNRELEASED; urgency=medium |
2 | 2 | ||
3 | * Add GitLab CI configuration. | 3 | * Add GitLab CI configuration. |
4 | * Make the autopkgtest create /run/sshd if it doesn't already exist. | ||
4 | 5 | ||
5 | -- Colin Watson <cjwatson@debian.org> Sat, 03 Nov 2018 16:28:16 +0000 | 6 | -- Colin Watson <cjwatson@debian.org> Sat, 03 Nov 2018 16:28:16 +0000 |
6 | 7 | ||
diff --git a/debian/tests/regress b/debian/tests/regress index e89e1940a..1c7a756f0 100755 --- a/debian/tests/regress +++ b/debian/tests/regress | |||
@@ -3,6 +3,7 @@ set -ex | |||
3 | 3 | ||
4 | if [ "$(id -un)" != openssh-tests ]; then | 4 | if [ "$(id -un)" != openssh-tests ]; then |
5 | TMP="$ADTTMP/user" | 5 | TMP="$ADTTMP/user" |
6 | CREATED_RUN_SSHD=false | ||
6 | STARTED_HAVEGED=false | 7 | STARTED_HAVEGED=false |
7 | 8 | ||
8 | cleanup () { | 9 | cleanup () { |
@@ -23,6 +24,10 @@ if [ "$(id -un)" != openssh-tests ]; then | |||
23 | if id openssh-tests >/dev/null 2>&1; then | 24 | if id openssh-tests >/dev/null 2>&1; then |
24 | deluser --remove-home openssh-tests | 25 | deluser --remove-home openssh-tests |
25 | fi | 26 | fi |
27 | |||
28 | if $CREATED_RUN_SSHD; then | ||
29 | rm -rf /run/sshd | ||
30 | fi | ||
26 | } | 31 | } |
27 | trap cleanup EXIT | 32 | trap cleanup EXIT |
28 | 33 | ||
@@ -35,6 +40,14 @@ EOF | |||
35 | cp -a . "$TMP/tree" | 40 | cp -a . "$TMP/tree" |
36 | chown -R openssh-tests:openssh-tests "$TMP" | 41 | chown -R openssh-tests:openssh-tests "$TMP" |
37 | 42 | ||
43 | # Depending on how the environment is configured, our test | ||
44 | # dependency on openssh-server may not actually started sshd and | ||
45 | # thus may not have caused /run/sshd to be created. | ||
46 | if [ ! -d /run/sshd ]; then | ||
47 | mkdir -m755 /run/sshd | ||
48 | CREATED_RUN_SSHD=: | ||
49 | fi | ||
50 | |||
38 | # If we're running in a container, haveged may not have started | 51 | # If we're running in a container, haveged may not have started |
39 | # automatically. | 52 | # automatically. |
40 | if [ -d /run/systemd/system ] && which systemctl >/dev/null 2>&1; then | 53 | if [ -d /run/systemd/system ] && which systemctl >/dev/null 2>&1; then |