summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-02-15 02:11:28 +0000
committerColin Watson <cjwatson@debian.org>2014-02-15 02:11:39 +0000
commit2fe6a8711420abb2751e1b36e880019e8fb134a1 (patch)
treeef6297a2a353f609318f0d4131e9b22119b73f4e /debian
parent99a7116957f4fe28a42db97edb20c424b4aa593d (diff)
parent18e1479bf4586a14b88dab082af10a8981b9d48d (diff)
Fix getsockname errors when using "ssh -W" (closes: #738693).
Diffstat (limited to 'debian')
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/getsockname-error.patch27
-rw-r--r--debian/patches/series1
4 files changed, 32 insertions, 2 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 5a2f70e06..f021dddb0 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
1# see git-dpm(1) from git-dpm package 1# see git-dpm(1) from git-dpm package
2bdb60d16baf6d163844fc6f5f8520bc853b6611b 218e1479bf4586a14b88dab082af10a8981b9d48d
3bdb60d16baf6d163844fc6f5f8520bc853b6611b 318e1479bf4586a14b88dab082af10a8981b9d48d
49a975a9faed7c4f334e8c8490db3e77e102f2b21 49a975a9faed7c4f334e8c8490db3e77e102f2b21
59a975a9faed7c4f334e8c8490db3e77e102f2b21 59a975a9faed7c4f334e8c8490db3e77e102f2b21
6openssh_6.5p1.orig.tar.gz 6openssh_6.5p1.orig.tar.gz
diff --git a/debian/changelog b/debian/changelog
index 6523de8a8..0cd7b9594 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,8 @@ openssh (1:6.5p1-4) UNRELEASED; urgency=medium
7 symlinks that won't work with dependency-based sysv-rc. 7 symlinks that won't work with dependency-based sysv-rc.
8 * Remove code related to non-dependency-based sysv-rc ordering, since that 8 * Remove code related to non-dependency-based sysv-rc ordering, since that
9 is no longer supported. 9 is no longer supported.
10 * Apply patch from https://bugzilla.mindrot.org/show_bug.cgi?id=2200 to
11 fix getsockname errors when using "ssh -W" (closes: #738693).
10 12
11 -- Colin Watson <cjwatson@debian.org> Thu, 13 Feb 2014 10:53:22 +0000 13 -- Colin Watson <cjwatson@debian.org> Thu, 13 Feb 2014 10:53:22 +0000
12 14
diff --git a/debian/patches/getsockname-error.patch b/debian/patches/getsockname-error.patch
new file mode 100644
index 000000000..b4dbc2c9f
--- /dev/null
+++ b/debian/patches/getsockname-error.patch
@@ -0,0 +1,27 @@
1From 18e1479bf4586a14b88dab082af10a8981b9d48d Mon Sep 17 00:00:00 2001
2From: Damien Miller <djm@mindrot.org>
3Date: Sat, 15 Feb 2014 02:08:20 +0000
4Subject: Skip get_sock_port call for c->sock==-1
5
6Origin: upstream, https://bugzilla.mindrot.org/show_bug.cgi?id=2200
7Bug-Debian: http://bugs.debian.org/738693
8Last-Update: 2014-02-15
9
10Patch-Name: getsockname-error.patch
11---
12 channels.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/channels.c b/channels.c
16index e741f29..8e66265 100644
17--- a/channels.c
18+++ b/channels.c
19@@ -1386,7 +1386,7 @@ port_open_helper(Channel *c, char *rtype)
20 int direct;
21 char buf[1024];
22 char *local_ipaddr = get_local_ipaddr(c->sock);
23- int local_port = get_sock_port(c->sock, 1);
24+ int local_port = c->sock == -1 ? 65536 : get_sock_port(c->sock, 1);
25 char *remote_ipaddr = get_peer_ipaddr(c->sock);
26 int remote_port = get_peer_port(c->sock);
27
diff --git a/debian/patches/series b/debian/patches/series
index f571f76a5..5048e254d 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -27,3 +27,4 @@ gnome-ssh-askpass2-icon.patch
27sigstop.patch 27sigstop.patch
28debian-config.patch 28debian-config.patch
29fix-case-sensitive-matching.patch 29fix-case-sensitive-matching.patch
30getsockname-error.patch