diff options
author | Colin Watson <cjwatson@debian.org> | 2003-09-01 23:01:22 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2003-09-01 23:01:22 +0000 |
commit | 3e106fd2d5f67598f1a38d918d32bac33f071dc1 (patch) | |
tree | 78bf276b639332272a6cdb6d74aa462b0b8e7b2c /debian | |
parent | b3485fdab48dc6bc85953c578f5f318bf1daa4c8 (diff) |
Use a more CVS-friendly means of setting SSH_VERSION.
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 6 | ||||
-rwxr-xr-x | debian/rules | 12 |
2 files changed, 10 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog index 9672dc4a3..253cde90f 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -1,3 +1,9 @@ | |||
1 | openssh (1:3.6.1p2-6) UNRELEASED; urgency=low | ||
2 | |||
3 | * Use a more CVS-friendly means of setting SSH_VERSION. | ||
4 | |||
5 | -- Colin Watson <cjwatson@debian.org> Mon, 1 Sep 2003 23:56:57 +0100 | ||
6 | |||
1 | openssh (1:3.6.1p2-5) unstable; urgency=low | 7 | openssh (1:3.6.1p2-5) unstable; urgency=low |
2 | 8 | ||
3 | * Disable cmsg_type check for file descriptor passing when running on | 9 | * Disable cmsg_type check for file descriptor passing when running on |
diff --git a/debian/rules b/debian/rules index 9ddaf5a80..ec594ecb0 100755 --- a/debian/rules +++ b/debian/rules | |||
@@ -25,17 +25,15 @@ PO2DEBCONF := yes | |||
25 | MINDEBCONFVER := 1.2.0 | 25 | MINDEBCONFVER := 1.2.0 |
26 | endif | 26 | endif |
27 | 27 | ||
28 | # Change the version string to include the Debian version | ||
29 | SSH_VERSION := $(shell sed -e '/define/!d; s/.*\"\(.*\)\".*/\1/; q' <version.h) Debian $(shell dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p') | ||
30 | |||
28 | build: build-stamp | 31 | build: build-stamp |
29 | build-stamp: | 32 | build-stamp: |
30 | dh_testdir | 33 | dh_testdir |
31 | #Change the version string to include the Debian Version | ||
32 | if <version.h sed -e "/define/s/\"\(.*\)\"/\"\1 Debian `dpkg-parsechangelog | sed -n -e '/^Version:/s/Version: //p'`\"/" >version.h.new; \ | ||
33 | then mv version.h version.h.upstream; mv version.h.new version.h; \ | ||
34 | else echo "Version number change failed"; exit 1; \ | ||
35 | fi | ||
36 | ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 \ | 34 | ./configure --prefix=/usr --sysconfdir=/etc/ssh --libexecdir=/usr/lib --mandir=/usr/share/man --with-tcp-wrappers --with-xauth=/usr/bin/X11/xauth --with-default-path=/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin --with-superuser-path=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/X11R6/bin --with-pam --with-4in6 \ |
37 | --with-privsep-path=/var/run/sshd --without-rand-helper | 35 | --with-privsep-path=/var/run/sshd --without-rand-helper |
38 | $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -fno-builtin-log -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED' \ | 36 | $(MAKE) -j 2 ASKPASS_PROGRAM='/usr/bin/ssh-askpass' CFLAGS='$(OPTFLAGS) -g -Wall -fno-builtin-log -DLOGIN_PROGRAM=\"/bin/login\" -DLOGIN_NO_ENDOPT -DSSHD_PAM_SERVICE=\"ssh\" -D__FILE_OFFSET_BITS=64 -DHAVE_MMAP_ANON_SHARED -DSSH_VERSION="\"$(SSH_VERSION)\""' \ |
39 | SSH_KEYSIGN='/usr/lib/ssh-keysign' | 37 | SSH_KEYSIGN='/usr/lib/ssh-keysign' |
40 | # Support building on Debian 3.0 (with GNOME 1.4) and later. | 38 | # Support building on Debian 3.0 (with GNOME 1.4) and later. |
41 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ | 39 | if [ -f /usr/include/libgnomeui-2.0/gnome.h ]; then \ |
@@ -52,8 +50,6 @@ clean: | |||
52 | -$(MAKE) -i distclean | 50 | -$(MAKE) -i distclean |
53 | -$(MAKE) -C contrib clean | 51 | -$(MAKE) -C contrib clean |
54 | rm -f config.log | 52 | rm -f config.log |
55 | if [ -f version.h.upstream ]; then mv version.h.upstream version.h; \ | ||
56 | fi | ||
57 | ifeq ($(PO2DEBCONF),yes) | 53 | ifeq ($(PO2DEBCONF),yes) |
58 | # Hack for woody compatibility. This makes sure that the | 54 | # Hack for woody compatibility. This makes sure that the |
59 | # debian/templates file shipped in the source package doesn't | 55 | # debian/templates file shipped in the source package doesn't |