summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2013-05-09 09:32:45 +0100
committerColin Watson <cjwatson@debian.org>2013-05-09 09:32:45 +0100
commit2bf02f2429738d820fd98de1078b5265696dbbb5 (patch)
tree5dc37df17c0e03f77b544eb87c0b5de9d6647ed7 /debian
parent0d6a7068412ff99144c5755d741dee7dd9cd97b2 (diff)
Fix consolekit mismerges in monitor.c and monitor_wrap.c.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/consolekit.patch22
2 files changed, 9 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index d0f19f9fe..d498fed04 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ openssh (1:6.2p1-2) UNRELEASED; urgency=low
2 2
3 * Fix build failure on Ubuntu: 3 * Fix build failure on Ubuntu:
4 - Include openbsd-compat/sys-queue.h from consolekit.c. 4 - Include openbsd-compat/sys-queue.h from consolekit.c.
5 - Fix consolekit mismerges in monitor.c and monitor_wrap.c.
5 6
6 -- Colin Watson <cjwatson@debian.org> Thu, 09 May 2013 00:55:50 +0100 7 -- Colin Watson <cjwatson@debian.org> Thu, 09 May 2013 00:55:50 +0100
7 8
diff --git a/debian/patches/consolekit.patch b/debian/patches/consolekit.patch
index 0d0a3d9d6..abc6839ba 100644
--- a/debian/patches/consolekit.patch
+++ b/debian/patches/consolekit.patch
@@ -553,10 +553,11 @@ Index: b/monitor.c
553 553
554 for (;;) 554 for (;;)
555 monitor_read(pmonitor, mon_dispatch, NULL); 555 monitor_read(pmonitor, mon_dispatch, NULL);
556@@ -2232,6 +2248,34 @@ 556@@ -2472,3 +2488,31 @@
557 buffer_put_int(m, major); 557 }
558 buffer_put_string(m, hash.value, hash.length);
559 558
559 #endif /* JPAKE */
560+
560+#ifdef USE_CONSOLEKIT 561+#ifdef USE_CONSOLEKIT
561+int 562+int
562+mm_answer_consolekit_register(int sock, Buffer *m) 563+mm_answer_consolekit_register(int sock, Buffer *m)
@@ -584,10 +585,6 @@ Index: b/monitor.c
584+ return (0); 585+ return (0);
585+} 586+}
586+#endif /* USE_CONSOLEKIT */ 587+#endif /* USE_CONSOLEKIT */
587+
588 mm_request_send(socket, MONITOR_ANS_GSSSIGN, m);
589
590 gss_release_buffer(&minor, &hash);
591Index: b/monitor.h 588Index: b/monitor.h
592=================================================================== 589===================================================================
593--- a/monitor.h 590--- a/monitor.h
@@ -605,10 +602,10 @@ Index: b/monitor_wrap.c
605=================================================================== 602===================================================================
606--- a/monitor_wrap.c 603--- a/monitor_wrap.c
607+++ b/monitor_wrap.c 604+++ b/monitor_wrap.c
608@@ -1311,6 +1311,37 @@ 605@@ -1514,3 +1514,34 @@
609 mm_ssh_gssapi_sign(Gssctxt *ctx, gss_buffer_desc *data, gss_buffer_desc *hash) 606 return success;
610 { 607 }
611 Buffer m; 608 #endif /* JPAKE */
612+ 609+
613+#ifdef USE_CONSOLEKIT 610+#ifdef USE_CONSOLEKIT
614+char * 611+char *
@@ -640,9 +637,6 @@ Index: b/monitor_wrap.c
640+ return (cookie); 637+ return (cookie);
641+} 638+}
642+#endif /* USE_CONSOLEKIT */ 639+#endif /* USE_CONSOLEKIT */
643 OM_uint32 major;
644 u_int len;
645
646Index: b/monitor_wrap.h 640Index: b/monitor_wrap.h
647=================================================================== 641===================================================================
648--- a/monitor_wrap.h 642--- a/monitor_wrap.h