summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2017-06-06 15:06:17 +0100
committerColin Watson <cjwatson@debian.org>2017-06-06 15:06:48 +0100
commit3c246c138b9f7fddcb726a8730f20ac7e588bfd0 (patch)
tree3262f7046a496eb527ca75eb189ab2754a48d8d7 /debian
parentca52d27d024543377671e0bec449f74384284074 (diff)
parent6111c39a4ae8f1c62a9312a5f8d8b23adb5f727a (diff)
Fix incoming compression statistics (thanks, Russell Coker; closes: #797964).
Diffstat (limited to 'debian')
-rw-r--r--debian/.git-dpm4
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/fix-incoming-compression-statistics.patch27
-rw-r--r--debian/patches/series1
4 files changed, 32 insertions, 2 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index bd533dda5..abee53f0a 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,6 +1,6 @@
1# see git-dpm(1) from git-dpm package 1# see git-dpm(1) from git-dpm package
293563703c3acd94883e89baa7fcbf666318e2704 26111c39a4ae8f1c62a9312a5f8d8b23adb5f727a
393563703c3acd94883e89baa7fcbf666318e2704 36111c39a4ae8f1c62a9312a5f8d8b23adb5f727a
46fabaf6fd9b07cc8bc6a17c9c4a5b76849cfc874 46fabaf6fd9b07cc8bc6a17c9c4a5b76849cfc874
56fabaf6fd9b07cc8bc6a17c9c4a5b76849cfc874 56fabaf6fd9b07cc8bc6a17c9c4a5b76849cfc874
6openssh_7.5p1.orig.tar.gz 6openssh_7.5p1.orig.tar.gz
diff --git a/debian/changelog b/debian/changelog
index 5dcf4438e..5010fe0c4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,8 @@ openssh (1:7.5p1-4) UNRELEASED; urgency=medium
4 optional. 4 optional.
5 * Only call "initctl set-env" from agent-launch if $UPSTART_SESSION is set 5 * Only call "initctl set-env" from agent-launch if $UPSTART_SESSION is set
6 (LP: #1689299). 6 (LP: #1689299).
7 * Fix incoming compression statistics (thanks, Russell Coker; closes:
8 #797964).
7 9
8 -- Colin Watson <cjwatson@debian.org> Wed, 03 May 2017 12:23:16 +0100 10 -- Colin Watson <cjwatson@debian.org> Wed, 03 May 2017 12:23:16 +0100
9 11
diff --git a/debian/patches/fix-incoming-compression-statistics.patch b/debian/patches/fix-incoming-compression-statistics.patch
new file mode 100644
index 000000000..42ebef3fb
--- /dev/null
+++ b/debian/patches/fix-incoming-compression-statistics.patch
@@ -0,0 +1,27 @@
1From 6111c39a4ae8f1c62a9312a5f8d8b23adb5f727a Mon Sep 17 00:00:00 2001
2From: Russell Coker <russell@coker.com.au>
3Date: Tue, 6 Jun 2017 15:00:20 +0100
4Subject: Fix incoming compression statistics
5
6Bug-Debian: https://bugs.debian.org/797964
7Forwarded: https://lists.mindrot.org/pipermail/openssh-unix-dev/2017-June/036077.html
8Last-Update: 2017-06-06
9
10Patch-Name: fix-incoming-compression-statistics.patch
11---
12 packet.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/packet.c b/packet.c
16index 2f3a2ec7..6492b66f 100644
17--- a/packet.c
18+++ b/packet.c
19@@ -606,7 +606,7 @@ ssh_packet_close(struct ssh *ssh)
20 deflateEnd(stream);
21 }
22 if (state->compression_in_started) {
23- z_streamp stream = &state->compression_out_stream;
24+ z_streamp stream = &state->compression_in_stream;
25 debug("compress incoming: "
26 "raw data %llu, compressed %llu, factor %.2f",
27 (unsigned long long)stream->total_out,
diff --git a/debian/patches/series b/debian/patches/series
index 981b5cf25..80ad5ec2b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -29,3 +29,4 @@ no-dsa-host-key-by-default.patch
29restore-authorized_keys2.patch 29restore-authorized_keys2.patch
30s390-missing-header.patch 30s390-missing-header.patch
31x32-syntax-error.patch 31x32-syntax-error.patch
32fix-incoming-compression-statistics.patch