diff options
author | Colin Watson <cjwatson@debian.org> | 2014-02-12 11:58:09 +0000 |
---|---|---|
committer | Colin Watson <cjwatson@debian.org> | 2014-02-12 11:58:09 +0000 |
commit | de5cb3521702a593b1abab37a9d54e93a80c40e7 (patch) | |
tree | 64ae7a529437c118ec488ab00cd25a75d31c20a4 /debian | |
parent | 01b5815d0ef4be4f74e2e152156f53dde4bc20c7 (diff) |
Fix sysvinit->systemd transition code
We need to cope with still-running sysvinit jobs being considered active by
systemd (thanks, Uoti Urpala and Michael Biebl).
Diffstat (limited to 'debian')
-rw-r--r-- | debian/changelog | 3 | ||||
-rw-r--r-- | debian/openssh-server.postinst | 5 |
2 files changed, 5 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog index c908bc162..6bf502848 100644 --- a/debian/changelog +++ b/debian/changelog | |||
@@ -5,6 +5,9 @@ openssh (1:6.5p1-3) UNRELEASED; urgency=medium | |||
5 | * Stop claiming that "Protocol 2" is a Debian-specific default; this has | 5 | * Stop claiming that "Protocol 2" is a Debian-specific default; this has |
6 | been upstream's default since 5.4p1. | 6 | been upstream's default since 5.4p1. |
7 | * Avoid stdout noise from which(1) on purge of openssh-client. | 7 | * Avoid stdout noise from which(1) on purge of openssh-client. |
8 | * Fix sysvinit->systemd transition code to cope with still-running | ||
9 | sysvinit jobs being considered active by systemd (thanks, Uoti Urpala | ||
10 | and Michael Biebl). | ||
8 | 11 | ||
9 | -- Colin Watson <cjwatson@debian.org> Tue, 11 Feb 2014 21:36:14 +0000 | 12 | -- Colin Watson <cjwatson@debian.org> Tue, 11 Feb 2014 21:36:14 +0000 |
10 | 13 | ||
diff --git a/debian/openssh-server.postinst b/debian/openssh-server.postinst index 72200604e..5f5787698 100644 --- a/debian/openssh-server.postinst +++ b/debian/openssh-server.postinst | |||
@@ -305,11 +305,10 @@ if [ "$action" = configure ]; then | |||
305 | start-stop-daemon --stop --quiet --oknodo --pidfile /var/run/sshd.pid || true | 305 | start-stop-daemon --stop --quiet --oknodo --pidfile /var/run/sshd.pid || true |
306 | fi | 306 | fi |
307 | if dpkg --compare-versions "$2" lt 1:6.5p1-1 && \ | 307 | if dpkg --compare-versions "$2" lt 1:6.5p1-1 && \ |
308 | [ -d /run/systemd/system ] && \ | 308 | [ -d /run/systemd/system ]; then |
309 | ! systemctl --quiet is-active ssh; then | ||
310 | # We must stop the sysvinit-controlled sshd before we can | 309 | # We must stop the sysvinit-controlled sshd before we can |
311 | # restart it under systemd. | 310 | # restart it under systemd. |
312 | start-stop-daemon --stop --quiet --oknodo --pidfile /var/run/sshd.pid || true | 311 | start-stop-daemon --stop --quiet --oknodo --pidfile /var/run/sshd.pid --exec /usr/sbin/sshd || true |
313 | fi | 312 | fi |
314 | if dpkg --compare-versions "$2" lt 1:6.5p1-2 && \ | 313 | if dpkg --compare-versions "$2" lt 1:6.5p1-2 && \ |
315 | deb-systemd-helper debian-installed ssh.socket && \ | 314 | deb-systemd-helper debian-installed ssh.socket && \ |