diff options
author | Damien Miller <djm@mindrot.org> | 1999-11-08 15:30:59 +1100 |
---|---|---|
committer | Damien Miller <djm@mindrot.org> | 1999-11-08 15:30:59 +1100 |
commit | 356a0b004aad93ec570b134664522a3a925ba556 (patch) | |
tree | 3c7cddb50f71a838947d5fda204b569d879dc757 /openssh.spec | |
parent | 0aa8e5395ca08c7fa927bccd8a763edc4ae61f7b (diff) |
Lots of changes:
- Removed lots of unnecessary checks from autoconf
- Added support and autoconf test for openpty() function (Unix98 pty support)
- Fix for scp not finding ssh if not installed as /usr/bin/ssh
- Added TODO file
- Merged parts of Debian patch From Phil Hands <phil@hands.com>:
- Added ssh-askpass program
- Added ssh-askpass support to ssh-add.c
- Create symlinks for slogin on install
- Fix "distclean" target in makefile
- Added example for ssh-agent to manpage
- Added support for PAM_TEXT_INFO messages
- Disable internal /etc/nologin support if PAM enabled
- Merged latest OpenBSD CVS changes:
- [sshd.c] don't send fail-msg but disconnect if too many authentication
failures
- [sshd.c] replace assert() with error, fatal or packet_disconnect
- [sshd.c] remove unused argument. ok dugsong
- [sshd.c] typo
- [rsa.c] clear buffers used for encryption. ok: niels
- [rsa.c] replace assert() with error, fatal or packet_disconnect
- Fixed coredump after merge of OpenBSD rsa.c patch
Diffstat (limited to 'openssh.spec')
-rw-r--r-- | openssh.spec | 23 |
1 files changed, 15 insertions, 8 deletions
diff --git a/openssh.spec b/openssh.spec index 4f50420ce..25b50491b 100644 --- a/openssh.spec +++ b/openssh.spec | |||
@@ -1,6 +1,6 @@ | |||
1 | Summary: OpenSSH free Secure Shell (SSH) implementation | 1 | Summary: OpenSSH free Secure Shell (SSH) implementation |
2 | Name: openssh | 2 | Name: openssh |
3 | Version: 1.2pre7 | 3 | Version: 1.2pre8 |
4 | Release: 1 | 4 | Release: 1 |
5 | Packager: Damien Miller <djm@ibs.com.au> | 5 | Packager: Damien Miller <djm@ibs.com.au> |
6 | Source0: openssh-%{version}-linux.tar.gz | 6 | Source0: openssh-%{version}-linux.tar.gz |
@@ -20,6 +20,9 @@ up to date in terms of security and features, as well as removing all | |||
20 | patented algorithms to seperate libraries (OpenSSL). | 20 | patented algorithms to seperate libraries (OpenSSL). |
21 | 21 | ||
22 | %changelog | 22 | %changelog |
23 | * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au> | ||
24 | - Added links for slogin | ||
25 | - Fixed perms on manpages | ||
23 | * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au> | 26 | * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au> |
24 | - Renamed init script | 27 | - Renamed init script |
25 | * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au> | 28 | * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au> |
@@ -60,6 +63,7 @@ install -s -m755 scp $RPM_BUILD_ROOT/usr/bin | |||
60 | install -s -m755 ssh-agent $RPM_BUILD_ROOT/usr/bin | 63 | install -s -m755 ssh-agent $RPM_BUILD_ROOT/usr/bin |
61 | install -s -m755 ssh-add $RPM_BUILD_ROOT/usr/bin | 64 | install -s -m755 ssh-add $RPM_BUILD_ROOT/usr/bin |
62 | install -s -m755 ssh-keygen $RPM_BUILD_ROOT/usr/bin | 65 | install -s -m755 ssh-keygen $RPM_BUILD_ROOT/usr/bin |
66 | ln -s ssh $RPM_BUILD_ROOT/usr/bin/slogin | ||
63 | 67 | ||
64 | install -m644 sshd.8 $RPM_BUILD_ROOT/usr/man/man8 | 68 | install -m644 sshd.8 $RPM_BUILD_ROOT/usr/man/man8 |
65 | install -m644 ssh.1 $RPM_BUILD_ROOT/usr/man/man1 | 69 | install -m644 ssh.1 $RPM_BUILD_ROOT/usr/man/man1 |
@@ -67,6 +71,7 @@ install -m644 scp.1 $RPM_BUILD_ROOT/usr/man/man1 | |||
67 | install -m644 ssh-agent.1 $RPM_BUILD_ROOT/usr/man/man1 | 71 | install -m644 ssh-agent.1 $RPM_BUILD_ROOT/usr/man/man1 |
68 | install -m644 ssh-add.1 $RPM_BUILD_ROOT/usr/man/man1 | 72 | install -m644 ssh-add.1 $RPM_BUILD_ROOT/usr/man/man1 |
69 | install -m644 ssh-keygen.1 $RPM_BUILD_ROOT/usr/man/man1 | 73 | install -m644 ssh-keygen.1 $RPM_BUILD_ROOT/usr/man/man1 |
74 | ln -s ssh.1 $RPM_BUILD_ROOT/usr/bin/slogin.1 | ||
70 | 75 | ||
71 | %clean | 76 | %clean |
72 | rm -rf $RPM_BUILD_ROOT | 77 | rm -rf $RPM_BUILD_ROOT |
@@ -98,13 +103,15 @@ fi | |||
98 | %attr(0755,root,root) /usr/bin/ssh-keygen | 103 | %attr(0755,root,root) /usr/bin/ssh-keygen |
99 | %attr(0755,root,root) /usr/bin/ssh-add | 104 | %attr(0755,root,root) /usr/bin/ssh-add |
100 | %attr(0755,root,root) /usr/bin/scp | 105 | %attr(0755,root,root) /usr/bin/scp |
101 | 106 | %attr(0755,root,root) /usr/bin/slogin | |
102 | %attr(0755,root,root) /usr/man/man8/sshd.8 | 107 | |
103 | %attr(0755,root,root) /usr/man/man1/ssh.1 | 108 | %attr(0644,root,root) /usr/man/man8/sshd.8 |
104 | %attr(0755,root,root) /usr/man/man1/ssh-agent.1 | 109 | %attr(0644,root,root) /usr/man/man1/ssh.1 |
105 | %attr(0755,root,root) /usr/man/man1/ssh-keygen.1 | 110 | %attr(0644,root,root) /usr/man/man1/ssh-agent.1 |
106 | %attr(0755,root,root) /usr/man/man1/ssh-add.1 | 111 | %attr(0644,root,root) /usr/man/man1/ssh-keygen.1 |
107 | %attr(0755,root,root) /usr/man/man1/scp.1 | 112 | %attr(0644,root,root) /usr/man/man1/ssh-add.1 |
113 | %attr(0644,root,root) /usr/man/man1/scp.1 | ||
114 | %attr(0644,root,root) /usr/man/man1/slogin.1 | ||
108 | 115 | ||
109 | %attr(0600,root,root) %config /etc/ssh/sshd_config | 116 | %attr(0600,root,root) %config /etc/ssh/sshd_config |
110 | %attr(0600,root,root) %config /etc/pam.d/sshd | 117 | %attr(0600,root,root) %config /etc/pam.d/sshd |