summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fcf7e416b..3e0821bae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.409 2008/07/09 11:07:19 djm Exp $ 1# $Id: configure.ac,v 1.410 2008/11/19 05:26:42 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.409 $) 18AC_REVISION($Revision: 1.410 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -2824,6 +2824,15 @@ AC_CACHE_CHECK([for struct in6_addr], ac_cv_have_struct_in6_addr, [
2824if test "x$ac_cv_have_struct_in6_addr" = "xyes" ; then 2824if test "x$ac_cv_have_struct_in6_addr" = "xyes" ; then
2825 AC_DEFINE(HAVE_STRUCT_IN6_ADDR, 1, 2825 AC_DEFINE(HAVE_STRUCT_IN6_ADDR, 1,
2826 [define if you have struct in6_addr data type]) 2826 [define if you have struct in6_addr data type])
2827
2828dnl Now check for sin6_scope_id
2829 AC_CHECK_MEMBERS([struct sockaddr_in6.sin6_scope_id],,,
2830 [
2831#ifdef HAVE_SYS_TYPES_H
2832#include <sys/types.h>
2833#endif
2834#include <netinet/in.h>
2835 ])
2827fi 2836fi
2828 2837
2829AC_CACHE_CHECK([for struct addrinfo], ac_cv_have_struct_addrinfo, [ 2838AC_CACHE_CHECK([for struct addrinfo], ac_cv_have_struct_addrinfo, [