summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2869f7042..ce16e7758 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1518,6 +1518,62 @@ else
1518 AC_MSG_RESULT([no]) 1518 AC_MSG_RESULT([no])
1519fi 1519fi
1520 1520
1521# Check whether user wants TCP wrappers support
1522TCPW_MSG="no"
1523AC_ARG_WITH([tcp-wrappers],
1524 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1525 [
1526 if test "x$withval" != "xno" ; then
1527 saved_LIBS="$LIBS"
1528 saved_LDFLAGS="$LDFLAGS"
1529 saved_CPPFLAGS="$CPPFLAGS"
1530 if test -n "${withval}" && \
1531 test "x${withval}" != "xyes"; then
1532 if test -d "${withval}/lib"; then
1533 if test -n "${need_dash_r}"; then
1534 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1535 else
1536 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1537 fi
1538 else
1539 if test -n "${need_dash_r}"; then
1540 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1541 else
1542 LDFLAGS="-L${withval} ${LDFLAGS}"
1543 fi
1544 fi
1545 if test -d "${withval}/include"; then
1546 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1547 else
1548 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1549 fi
1550 fi
1551 LIBS="-lwrap $LIBS"
1552 AC_MSG_CHECKING([for libwrap])
1553 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1554#include <sys/types.h>
1555#include <sys/socket.h>
1556#include <netinet/in.h>
1557#include <tcpd.h>
1558int deny_severity = 0, allow_severity = 0;
1559 ]], [[
1560 hosts_access(0);
1561 ]])], [
1562 AC_MSG_RESULT([yes])
1563 AC_DEFINE([LIBWRAP], [1],
1564 [Define if you want
1565 TCP Wrappers support])
1566 SSHDLIBS="$SSHDLIBS -lwrap"
1567 TCPW_MSG="yes"
1568 ], [
1569 AC_MSG_ERROR([*** libwrap missing])
1570
1571 ])
1572 LIBS="$saved_LIBS"
1573 fi
1574 ]
1575)
1576
1521# Check whether user wants to use ldns 1577# Check whether user wants to use ldns
1522LDNS_MSG="no" 1578LDNS_MSG="no"
1523AC_ARG_WITH(ldns, 1579AC_ARG_WITH(ldns,
@@ -5269,6 +5325,7 @@ echo " PAM support: $PAM_MSG"
5269echo " OSF SIA support: $SIA_MSG" 5325echo " OSF SIA support: $SIA_MSG"
5270echo " KerberosV support: $KRB5_MSG" 5326echo " KerberosV support: $KRB5_MSG"
5271echo " SELinux support: $SELINUX_MSG" 5327echo " SELinux support: $SELINUX_MSG"
5328echo " TCP Wrappers support: $TCPW_MSG"
5272echo " MD5 password support: $MD5_MSG" 5329echo " MD5 password support: $MD5_MSG"
5273echo " libedit support: $LIBEDIT_MSG" 5330echo " libedit support: $LIBEDIT_MSG"
5274echo " libldns support: $LDNS_MSG" 5331echo " libldns support: $LDNS_MSG"