diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 10 |
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac index 663062bef..1e9f7412c 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -274,7 +274,7 @@ typedef void foo(const char *, ...) __attribute__((format(printf, 1, 2)));]], | |||
274 | [ AC_MSG_RESULT([yes]) ], | 274 | [ AC_MSG_RESULT([yes]) ], |
275 | [ AC_MSG_RESULT([no]) | 275 | [ AC_MSG_RESULT([no]) |
276 | AC_DEFINE(NO_ATTRIBUTE_ON_PROTOTYPE_ARGS, 1, | 276 | AC_DEFINE(NO_ATTRIBUTE_ON_PROTOTYPE_ARGS, 1, |
277 | [compiler does not accept __attribute__ on protoype args]) ] | 277 | [compiler does not accept __attribute__ on prototype args]) ] |
278 | ) | 278 | ) |
279 | 279 | ||
280 | if test "x$no_attrib_nonnull" != "x1" ; then | 280 | if test "x$no_attrib_nonnull" != "x1" ; then |
@@ -514,7 +514,7 @@ case "$host" in | |||
514 | # Some versions of VAC won't allow macro redefinitions at | 514 | # Some versions of VAC won't allow macro redefinitions at |
515 | # -qlanglevel=ansi, and autoconf 2.60 sometimes insists on using that | 515 | # -qlanglevel=ansi, and autoconf 2.60 sometimes insists on using that |
516 | # particularly with older versions of vac or xlc. | 516 | # particularly with older versions of vac or xlc. |
517 | # It also throws errors about null macro argments, but these are | 517 | # It also throws errors about null macro arguments, but these are |
518 | # not fatal. | 518 | # not fatal. |
519 | AC_MSG_CHECKING([if compiler allows macro redefinitions]) | 519 | AC_MSG_CHECKING([if compiler allows macro redefinitions]) |
520 | AC_COMPILE_IFELSE( | 520 | AC_COMPILE_IFELSE( |
@@ -753,7 +753,7 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
753 | PATH="$PATH:/usr/etc" | 753 | PATH="$PATH:/usr/etc" |
754 | AC_DEFINE([WITH_IRIX_ARRAY], [1], | 754 | AC_DEFINE([WITH_IRIX_ARRAY], [1], |
755 | [Define if you have/want arrays | 755 | [Define if you have/want arrays |
756 | (cluster-wide session managment, not C arrays)]) | 756 | (cluster-wide session management, not C arrays)]) |
757 | AC_DEFINE([WITH_IRIX_PROJECT], [1], | 757 | AC_DEFINE([WITH_IRIX_PROJECT], [1], |
758 | [Define if you want IRIX project management]) | 758 | [Define if you want IRIX project management]) |
759 | AC_DEFINE([WITH_IRIX_AUDIT], [1], | 759 | AC_DEFINE([WITH_IRIX_AUDIT], [1], |
@@ -3005,7 +3005,7 @@ LIBS="$saved_LIBS" | |||
3005 | 3005 | ||
3006 | ### Configure cryptographic random number support | 3006 | ### Configure cryptographic random number support |
3007 | 3007 | ||
3008 | # Check wheter OpenSSL seeds itself | 3008 | # Check whether OpenSSL seeds itself |
3009 | if test "x$openssl" = "xyes" ; then | 3009 | if test "x$openssl" = "xyes" ; then |
3010 | AC_MSG_CHECKING([whether OpenSSL's PRNG is internally seeded]) | 3010 | AC_MSG_CHECKING([whether OpenSSL's PRNG is internally seeded]) |
3011 | AC_RUN_IFELSE( | 3011 | AC_RUN_IFELSE( |
@@ -3904,7 +3904,7 @@ fi | |||
3904 | 3904 | ||
3905 | AC_CHECK_TYPES([struct timespec]) | 3905 | AC_CHECK_TYPES([struct timespec]) |
3906 | 3906 | ||
3907 | # We need int64_t or else certian parts of the compile will fail. | 3907 | # We need int64_t or else certain parts of the compile will fail. |
3908 | if test "x$ac_cv_have_int64_t" = "xno" && \ | 3908 | if test "x$ac_cv_have_int64_t" = "xno" && \ |
3909 | test "x$ac_cv_sizeof_long_int" != "x8" && \ | 3909 | test "x$ac_cv_sizeof_long_int" != "x8" && \ |
3910 | test "x$ac_cv_sizeof_long_long_int" = "x0" ; then | 3910 | test "x$ac_cv_sizeof_long_long_int" = "x0" ; then |