diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 12 |
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 35e2e8d1d..0ba2ff442 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -265,6 +265,18 @@ __attribute__((__unused__)) static void foo(void){return;}]], | |||
265 | [compiler does not accept __attribute__ on return types]) ] | 265 | [compiler does not accept __attribute__ on return types]) ] |
266 | ) | 266 | ) |
267 | 267 | ||
268 | AC_MSG_CHECKING([if compiler allows __attribute__ prototype args]) | ||
269 | AC_COMPILE_IFELSE( | ||
270 | [AC_LANG_PROGRAM([[ | ||
271 | #include <stdlib.h> | ||
272 | typedef void foo(const char *, ...) __attribute__((format(printf, 1, 2)));]], | ||
273 | [[ exit(0); ]])], | ||
274 | [ AC_MSG_RESULT([yes]) ], | ||
275 | [ AC_MSG_RESULT([no]) | ||
276 | AC_DEFINE(NO_ATTRIBUTE_ON_PROTOTYPE_ARGS, 1, | ||
277 | [compiler does not accept __attribute__ on protoype args]) ] | ||
278 | ) | ||
279 | |||
268 | if test "x$no_attrib_nonnull" != "x1" ; then | 280 | if test "x$no_attrib_nonnull" != "x1" ; then |
269 | AC_DEFINE([HAVE_ATTRIBUTE__NONNULL__], [1], [Have attribute nonnull]) | 281 | AC_DEFINE([HAVE_ATTRIBUTE__NONNULL__], [1], [Have attribute nonnull]) |
270 | fi | 282 | fi |