diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 17 |
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac index 0447bd62d..88a248fb5 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.430 2009/10/11 10:50:20 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.431 2009/12/07 00:15:43 dtucker Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -15,7 +15,7 @@ | |||
15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. | 15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. |
16 | 16 | ||
17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) | 17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) |
18 | AC_REVISION($Revision: 1.430 $) | 18 | AC_REVISION($Revision: 1.431 $) |
19 | AC_CONFIG_SRCDIR([ssh.c]) | 19 | AC_CONFIG_SRCDIR([ssh.c]) |
20 | 20 | ||
21 | AC_CONFIG_HEADER(config.h) | 21 | AC_CONFIG_HEADER(config.h) |
@@ -3295,11 +3295,18 @@ AC_ARG_WITH(opensc, | |||
3295 | [ --with-opensc[[=PFX]] Enable smartcard support using OpenSC (optionally in PATH)], | 3295 | [ --with-opensc[[=PFX]] Enable smartcard support using OpenSC (optionally in PATH)], |
3296 | [ | 3296 | [ |
3297 | if test "x$withval" != "xno" ; then | 3297 | if test "x$withval" != "xno" ; then |
3298 | if test "x$withval" != "xyes" ; then | 3298 | AC_PATH_PROG(PKGCONFIG, pkg-config, no) |
3299 | OPENSC_CONFIG=$withval/bin/opensc-config | 3299 | AC_MSG_CHECKING(how to get opensc config) |
3300 | if test "x$withval" != "xyes" -a "x$PKGCONFIG" = "xno"; then | ||
3301 | OPENSC_CONFIG="$withval/bin/opensc-config" | ||
3302 | elif test -f "$withval/src/libopensc/libopensc.pc"; then | ||
3303 | OPENSC_CONFIG="$PKGCONFIG $withval/src/libopensc/libopensc.pc" | ||
3304 | elif test "x$PKGCONFIG" != "xno"; then | ||
3305 | OPENSC_CONFIG="$PKGCONFIG libopensc" | ||
3300 | else | 3306 | else |
3301 | AC_PATH_PROG(OPENSC_CONFIG, opensc-config, no) | 3307 | AC_PATH_PROG(OPENSC_CONFIG, opensc-config, no) |
3302 | fi | 3308 | fi |
3309 | AC_MSG_RESULT($OPENSC_CONFIG) | ||
3303 | if test "$OPENSC_CONFIG" != "no"; then | 3310 | if test "$OPENSC_CONFIG" != "no"; then |
3304 | LIBOPENSC_CFLAGS=`$OPENSC_CONFIG --cflags` | 3311 | LIBOPENSC_CFLAGS=`$OPENSC_CONFIG --cflags` |
3305 | LIBOPENSC_LIBS=`$OPENSC_CONFIG --libs` | 3312 | LIBOPENSC_LIBS=`$OPENSC_CONFIG --libs` |