diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 65 |
1 files changed, 39 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac index 9f59794bc..9d89bc351 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -764,6 +764,9 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
764 | use_pie=auto | 764 | use_pie=auto |
765 | check_for_libcrypt_later=1 | 765 | check_for_libcrypt_later=1 |
766 | check_for_openpty_ctty_bug=1 | 766 | check_for_openpty_ctty_bug=1 |
767 | dnl Target SUSv3/POSIX.1-2001 plus BSD specifics. | ||
768 | dnl _DEFAULT_SOURCE is the new name for _BSD_SOURCE | ||
769 | CPPFLAGS="$CPPFLAGS -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_DEFAULT_SOURCE" | ||
767 | AC_DEFINE([PAM_TTY_KLUDGE], [1], | 770 | AC_DEFINE([PAM_TTY_KLUDGE], [1], |
768 | [Work around problematic Linux PAM modules handling of PAM_TTY]) | 771 | [Work around problematic Linux PAM modules handling of PAM_TTY]) |
769 | AC_DEFINE([LOCKED_PASSWD_PREFIX], ["!"], | 772 | AC_DEFINE([LOCKED_PASSWD_PREFIX], ["!"], |
@@ -1551,36 +1554,47 @@ int deny_severity = 0, allow_severity = 0; | |||
1551 | LDNS_MSG="no" | 1554 | LDNS_MSG="no" |
1552 | AC_ARG_WITH(ldns, | 1555 | AC_ARG_WITH(ldns, |
1553 | [ --with-ldns[[=PATH]] Use ldns for DNSSEC support (optionally in PATH)], | 1556 | [ --with-ldns[[=PATH]] Use ldns for DNSSEC support (optionally in PATH)], |
1554 | [ | 1557 | [ |
1555 | if test "x$withval" != "xno" ; then | 1558 | ldns="" |
1556 | 1559 | if test "x$withval" = "xyes" ; then | |
1557 | if test "x$withval" != "xyes" ; then | 1560 | AC_PATH_TOOL([LDNSCONFIG], [ldns-config], [no]) |
1558 | CPPFLAGS="$CPPFLAGS -I${withval}/include" | 1561 | if test "x$PKGCONFIG" = "xno"; then |
1559 | LDFLAGS="$LDFLAGS -L${withval}/lib" | 1562 | CPPFLAGS="$CPPFLAGS -I${withval}/include" |
1560 | fi | 1563 | LDFLAGS="$LDFLAGS -L${withval}/lib" |
1561 | 1564 | LIBS="-lldns $LIBS" | |
1562 | AC_DEFINE(HAVE_LDNS, 1, [Define if you want ldns support]) | 1565 | ldns=yes |
1563 | LIBS="-lldns $LIBS" | 1566 | else |
1564 | LDNS_MSG="yes" | 1567 | LIBS="$LIBS `$LDNSCONFIG --libs`" |
1568 | CPPFLAGS="$CPPFLAGS `$LDNSCONFIG --cflags`" | ||
1569 | fi | ||
1570 | elif test "x$withval" != "xno" ; then | ||
1571 | CPPFLAGS="$CPPFLAGS -I${withval}/include" | ||
1572 | LDFLAGS="$LDFLAGS -L${withval}/lib" | ||
1573 | LIBS="-lldns $LIBS" | ||
1574 | ldns=yes | ||
1575 | fi | ||
1565 | 1576 | ||
1566 | AC_MSG_CHECKING([for ldns support]) | 1577 | # Verify that it works. |
1567 | AC_LINK_IFELSE( | 1578 | if test "x$ldns" = "xyes" ; then |
1568 | [AC_LANG_SOURCE([[ | 1579 | AC_DEFINE(HAVE_LDNS, 1, [Define if you want ldns support]) |
1580 | LDNS_MSG="yes" | ||
1581 | AC_MSG_CHECKING([for ldns support]) | ||
1582 | AC_LINK_IFELSE( | ||
1583 | [AC_LANG_SOURCE([[ | ||
1569 | #include <stdio.h> | 1584 | #include <stdio.h> |
1570 | #include <stdlib.h> | 1585 | #include <stdlib.h> |
1571 | #include <stdint.h> | 1586 | #include <stdint.h> |
1572 | #include <ldns/ldns.h> | 1587 | #include <ldns/ldns.h> |
1573 | int main() { ldns_status status = ldns_verify_trusted(NULL, NULL, NULL, NULL); status=LDNS_STATUS_OK; exit(0); } | 1588 | int main() { ldns_status status = ldns_verify_trusted(NULL, NULL, NULL, NULL); status=LDNS_STATUS_OK; exit(0); } |
1574 | ]]) | 1589 | ]]) |
1575 | ], | 1590 | ], |
1576 | [AC_MSG_RESULT(yes)], | 1591 | [AC_MSG_RESULT(yes)], |
1577 | [ | 1592 | [ |
1578 | AC_MSG_RESULT(no) | 1593 | AC_MSG_RESULT(no) |
1579 | AC_MSG_ERROR([** Incomplete or missing ldns libraries.]) | 1594 | AC_MSG_ERROR([** Incomplete or missing ldns libraries.]) |
1580 | ]) | 1595 | ]) |
1581 | fi | 1596 | fi |
1582 | ] | 1597 | ]) |
1583 | ) | ||
1584 | 1598 | ||
1585 | # Check whether user wants libedit support | 1599 | # Check whether user wants libedit support |
1586 | LIBEDIT_MSG="no" | 1600 | LIBEDIT_MSG="no" |
@@ -1783,6 +1797,7 @@ AC_CHECK_FUNCS([ \ | |||
1783 | inet_ntoa \ | 1797 | inet_ntoa \ |
1784 | inet_ntop \ | 1798 | inet_ntop \ |
1785 | innetgr \ | 1799 | innetgr \ |
1800 | llabs \ | ||
1786 | login_getcapbool \ | 1801 | login_getcapbool \ |
1787 | md5_crypt \ | 1802 | md5_crypt \ |
1788 | memmove \ | 1803 | memmove \ |
@@ -1851,11 +1866,8 @@ AC_CHECK_FUNCS([ \ | |||
1851 | warn \ | 1866 | warn \ |
1852 | ]) | 1867 | ]) |
1853 | 1868 | ||
1854 | dnl Wide character support. Linux man page says it needs _XOPEN_SOURCE. | 1869 | dnl Wide character support. |
1855 | saved_CFLAGS="$CFLAGS" | ||
1856 | CFLAGS="$CFLAGS -D_XOPEN_SOURCE" | ||
1857 | AC_CHECK_FUNCS([mblen mbtowc nl_langinfo wcwidth]) | 1870 | AC_CHECK_FUNCS([mblen mbtowc nl_langinfo wcwidth]) |
1858 | CFLAGS="$saved_CFLAGS" | ||
1859 | 1871 | ||
1860 | TEST_SSH_UTF8=${TEST_SSH_UTF8:=yes} | 1872 | TEST_SSH_UTF8=${TEST_SSH_UTF8:=yes} |
1861 | AC_MSG_CHECKING([for utf8 locale support]) | 1873 | AC_MSG_CHECKING([for utf8 locale support]) |
@@ -2600,8 +2612,8 @@ if test "x$openssl" = "xyes" ; then | |||
2600 | ssl_library_ver=`cat conftest.ssllibver` | 2612 | ssl_library_ver=`cat conftest.ssllibver` |
2601 | # Check version is supported. | 2613 | # Check version is supported. |
2602 | case "$ssl_library_ver" in | 2614 | case "$ssl_library_ver" in |
2603 | 0090[[0-7]]*|009080[[0-5]]*) | 2615 | 10000*|0*) |
2604 | AC_MSG_ERROR([OpenSSL >= 0.9.8f required (have "$ssl_library_ver")]) | 2616 | AC_MSG_ERROR([OpenSSL >= 1.0.1 required (have "$ssl_library_ver")]) |
2605 | ;; | 2617 | ;; |
2606 | *) ;; | 2618 | *) ;; |
2607 | esac | 2619 | esac |
@@ -5187,6 +5199,7 @@ echo " S/KEY support: $SKEY_MSG" | |||
5187 | echo " TCP Wrappers support: $TCPW_MSG" | 5199 | echo " TCP Wrappers support: $TCPW_MSG" |
5188 | echo " MD5 password support: $MD5_MSG" | 5200 | echo " MD5 password support: $MD5_MSG" |
5189 | echo " libedit support: $LIBEDIT_MSG" | 5201 | echo " libedit support: $LIBEDIT_MSG" |
5202 | echo " libldns support: $LDNS_MSG" | ||
5190 | echo " Solaris process contract support: $SPC_MSG" | 5203 | echo " Solaris process contract support: $SPC_MSG" |
5191 | echo " Solaris project support: $SP_MSG" | 5204 | echo " Solaris project support: $SP_MSG" |
5192 | echo " Solaris privilege support: $SPP_MSG" | 5205 | echo " Solaris privilege support: $SPP_MSG" |