summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e2289cd37..86692714b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.568 2014/01/30 00:26:46 djm Exp $ 1# $Id: configure.ac,v 1.571 2014/02/21 17:09:34 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.568 $) 18AC_REVISION($Revision: 1.571 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -809,7 +809,7 @@ mips-sony-bsd|mips-sony-newsos4)
809 # Preauth crypto occasionally uses file descriptors for crypto offload 809 # Preauth crypto occasionally uses file descriptors for crypto offload
810 # and will crash if they cannot be opened. 810 # and will crash if they cannot be opened.
811 AC_DEFINE([SANDBOX_SKIP_RLIMIT_NOFILE], [1], 811 AC_DEFINE([SANDBOX_SKIP_RLIMIT_NOFILE], [1],
812 [define if setrlimit RLIMIT_NOFILE breaks things])], 812 [define if setrlimit RLIMIT_NOFILE breaks things])
813 ;; 813 ;;
814*-*-bsdi*) 814*-*-bsdi*)
815 AC_DEFINE([SETEUID_BREAKS_SETUID]) 815 AC_DEFINE([SETEUID_BREAKS_SETUID])
@@ -1673,6 +1673,7 @@ AC_CHECK_FUNCS([ \
1673 closefrom \ 1673 closefrom \
1674 dirfd \ 1674 dirfd \
1675 endgrent \ 1675 endgrent \
1676 explicit_bzero \
1676 fchmod \ 1677 fchmod \
1677 fchown \ 1678 fchown \
1678 freeaddrinfo \ 1679 freeaddrinfo \
@@ -2453,6 +2454,7 @@ AC_CHECK_FUNCS([ \
2453 EVP_DigestFinal_ex \ 2454 EVP_DigestFinal_ex \
2454 EVP_MD_CTX_init \ 2455 EVP_MD_CTX_init \
2455 EVP_MD_CTX_cleanup \ 2456 EVP_MD_CTX_cleanup \
2457 EVP_MD_CTX_copy_ex \
2456 HMAC_CTX_init \ 2458 HMAC_CTX_init \
2457 RSA_generate_key_ex \ 2459 RSA_generate_key_ex \
2458 RSA_get_default_method \ 2460 RSA_get_default_method \