summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b689db4b5..efafb6bd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -674,6 +674,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
674 [Use tunnel device compatibility to OpenBSD]) 674 [Use tunnel device compatibility to OpenBSD])
675 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 675 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
676 [Prepend the address family to IP tunnel traffic]) 676 [Prepend the address family to IP tunnel traffic])
677 AC_MSG_CHECKING([if we have the Security Authorization Session API])
678 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
679 [SessionCreate(0, 0);],
680 [ac_cv_use_security_session_api="yes"
681 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
682 [platform has the Security Authorization Session API])
683 LIBS="$LIBS -framework Security"
684 AC_MSG_RESULT([yes])],
685 [ac_cv_use_security_session_api="no"
686 AC_MSG_RESULT([no])])
687 AC_MSG_CHECKING([if we have an in-memory credentials cache])
688 AC_TRY_COMPILE(
689 [#include <Kerberos/Kerberos.h>],
690 [cc_context_t c;
691 (void) cc_initialize (&c, 0, NULL, NULL);],
692 [AC_DEFINE([USE_CCAPI], [1],
693 [platform uses an in-memory credentials cache])
694 LIBS="$LIBS -framework Security"
695 AC_MSG_RESULT([yes])
696 if test "x$ac_cv_use_security_session_api" = "xno"; then
697 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
698 fi],
699 [AC_MSG_RESULT([no])]
700 )
677 m4_pattern_allow([AU_IPv]) 701 m4_pattern_allow([AU_IPv])
678 AC_CHECK_DECL([AU_IPv4], [], 702 AC_CHECK_DECL([AU_IPv4], [],
679 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 703 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])