summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 91a4c4eeb..6b1c3137f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.197 2004/02/11 22:46:40 tim Exp $ 1# $Id: configure.ac,v 1.198 2004/02/12 17:27:21 tim Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -1021,12 +1021,6 @@ if test "x$PAM_MSG" = "xyes" ; then
1021 ) 1021 )
1022fi 1022fi
1023 1023
1024# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
1025# because the system crypt() is more featureful.
1026if test "x$check_for_libcrypt_before" = "x1"; then
1027 AC_CHECK_LIB(crypt, crypt)
1028fi
1029
1030# Search for OpenSSL 1024# Search for OpenSSL
1031saved_CPPFLAGS="$CPPFLAGS" 1025saved_CPPFLAGS="$CPPFLAGS"
1032saved_LDFLAGS="$LDFLAGS" 1026saved_LDFLAGS="$LDFLAGS"
@@ -1055,7 +1049,7 @@ AC_ARG_WITH(ssl-dir,
1055 fi 1049 fi
1056 ] 1050 ]
1057) 1051)
1058LIBS="$LIBS -lcrypto" 1052LIBS="-lcrypto $LIBS"
1059AC_TRY_LINK_FUNC(RAND_add, AC_DEFINE(HAVE_OPENSSL), 1053AC_TRY_LINK_FUNC(RAND_add, AC_DEFINE(HAVE_OPENSSL),
1060 [ 1054 [
1061 dnl Check default openssl install dir 1055 dnl Check default openssl install dir
@@ -1157,6 +1151,12 @@ Also see contrib/findssl.sh for help identifying header/library mismatches.])
1157 ] 1151 ]
1158) 1152)
1159 1153
1154# Some systems want crypt() from libcrypt, *not* the version in OpenSSL,
1155# because the system crypt() is more featureful.
1156if test "x$check_for_libcrypt_before" = "x1"; then
1157 AC_CHECK_LIB(crypt, crypt)
1158fi
1159
1160# Some Linux systems (Slackware) need crypt() from libcrypt, *not* the 1160# Some Linux systems (Slackware) need crypt() from libcrypt, *not* the
1161# version in OpenSSL. 1161# version in OpenSSL.
1162if test "x$check_for_libcrypt_later" = "x1"; then 1162if test "x$check_for_libcrypt_later" = "x1"; then