summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 20 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index ba9d9a37a..991e0fef3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -473,6 +473,11 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
473 [Use tunnel device compatibility to OpenBSD]) 473 [Use tunnel device compatibility to OpenBSD])
474 AC_DEFINE(SSH_TUN_PREPEND_AF, 1, 474 AC_DEFINE(SSH_TUN_PREPEND_AF, 1,
475 [Prepend the address family to IP tunnel traffic]) 475 [Prepend the address family to IP tunnel traffic])
476 m4_pattern_allow(AU_IPv)
477 AC_CHECK_DECL(AU_IPv4, [],
478 AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records])
479 [#include <bsm/audit.h>]
480 )
476 AC_MSG_CHECKING(if we have the Security Authorization Session API) 481 AC_MSG_CHECKING(if we have the Security Authorization Session API)
477 AC_TRY_COMPILE([#include <Security/AuthSession.h>], 482 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
478 [SessionCreate(0, 0);], 483 [SessionCreate(0, 0);],
@@ -497,11 +502,6 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
497 fi], 502 fi],
498 [AC_MSG_RESULT(no)] 503 [AC_MSG_RESULT(no)]
499 ) 504 )
500 m4_pattern_allow(AU_IPv)
501 AC_CHECK_DECL(AU_IPv4, [],
502 AC_DEFINE(AU_IPv4, 0, [System only supports IPv4 audit records])
503 [#include <bsm/audit.h>]
504 )
505 ;; 505 ;;
506*-*-dragonfly*) 506*-*-dragonfly*)
507 SSHDLIBS="$SSHDLIBS -lcrypt" 507 SSHDLIBS="$SSHDLIBS -lcrypt"
@@ -585,6 +585,14 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
585 AC_DEFINE(WITH_ABBREV_NO_TTY) 585 AC_DEFINE(WITH_ABBREV_NO_TTY)
586 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") 586 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*")
587 ;; 587 ;;
588*-*-k*bsd*-gnu)
589 check_for_libcrypt_later=1
590 AC_DEFINE(PAM_TTY_KLUDGE)
591 AC_DEFINE(LOCKED_PASSWD_PREFIX, "!")
592 AC_DEFINE(SPT_TYPE,SPT_REUSEARGV)
593 AC_DEFINE(_PATH_BTMP, "/var/log/btmp", [log for bad login attempts])
594 AC_DEFINE(USE_BTMP, 1, [Use btmp to log bad logins])
595 ;;
588*-*-linux*) 596*-*-linux*)
589 no_dev_ptmx=1 597 no_dev_ptmx=1
590 check_for_libcrypt_later=1 598 check_for_libcrypt_later=1
@@ -616,6 +624,7 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
616 AC_DEFINE(SSH_TUN_PREPEND_AF, 1, 624 AC_DEFINE(SSH_TUN_PREPEND_AF, 1,
617 [Prepend the address family to IP tunnel traffic]) 625 [Prepend the address family to IP tunnel traffic])
618 fi 626 fi
627 AC_DEFINE(OOM_ADJUST, 1, [Adjust Linux out-of-memory killer])
619 ;; 628 ;;
620mips-sony-bsd|mips-sony-newsos4) 629mips-sony-bsd|mips-sony-newsos4)
621 AC_DEFINE(NEED_SETPGRP, 1, [Need setpgrp to acquire controlling tty]) 630 AC_DEFINE(NEED_SETPGRP, 1, [Need setpgrp to acquire controlling tty])
@@ -3329,9 +3338,12 @@ AC_ARG_WITH(selinux,
3329 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.]) 3338 AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.])
3330 SELINUX_MSG="yes" 3339 SELINUX_MSG="yes"
3331 AC_CHECK_HEADER([selinux/selinux.h], , 3340 AC_CHECK_HEADER([selinux/selinux.h], ,
3332 AC_MSG_ERROR(SELinux support requires selinux.h header)) 3341 AC_MSG_ERROR(SELinux support requires selinux.h header))
3333 AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ], 3342 AC_CHECK_LIB(selinux, setexeccon,
3334 AC_MSG_ERROR(SELinux support requires libselinux library)) 3343 [ LIBSELINUX="-lselinux"
3344 LIBS="$LIBS -lselinux"
3345 ],
3346 AC_MSG_ERROR(SELinux support requires libselinux library))
3335 SSHDLIBS="$SSHDLIBS $LIBSELINUX" 3347 SSHDLIBS="$SSHDLIBS $LIBSELINUX"
3336 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level) 3348 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
3337 LIBS="$save_LIBS" 3349 LIBS="$save_LIBS"