diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 22 |
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac index 9e037ab0e..093c17643 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.338 2006/03/15 21:14:34 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.339 2006/04/22 11:26:08 djm Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -15,7 +15,7 @@ | |||
15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. | 15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. |
16 | 16 | ||
17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) | 17 | AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) |
18 | AC_REVISION($Revision: 1.338 $) | 18 | AC_REVISION($Revision: 1.339 $) |
19 | AC_CONFIG_SRCDIR([ssh.c]) | 19 | AC_CONFIG_SRCDIR([ssh.c]) |
20 | 20 | ||
21 | AC_CONFIG_HEADER(config.h) | 21 | AC_CONFIG_HEADER(config.h) |
@@ -3000,6 +3000,23 @@ int main() | |||
3000 | [#include <arpa/nameser.h>]) | 3000 | [#include <arpa/nameser.h>]) |
3001 | ]) | 3001 | ]) |
3002 | 3002 | ||
3003 | # Check whether user wants SELinux support | ||
3004 | SELINUX_MSG="no" | ||
3005 | LIBSELINUX="" | ||
3006 | AC_ARG_WITH(selinux, | ||
3007 | [ --with-selinux Enable SELinux support], | ||
3008 | [ if test "x$withval" != "xno" ; then | ||
3009 | AC_DEFINE(WITH_SELINUX,1,[Define if you want SELinux support.]) | ||
3010 | SELINUX_MSG="yes" | ||
3011 | AC_CHECK_HEADER([selinux/selinux.h], , | ||
3012 | AC_MSG_ERROR(SELinux support requires selinux.h header)) | ||
3013 | AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ], | ||
3014 | AC_MSG_ERROR(SELinux support requires libselinux library)) | ||
3015 | AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level) | ||
3016 | fi ] | ||
3017 | ) | ||
3018 | AC_SUBST(LIBSELINUX) | ||
3019 | |||
3003 | # Check whether user wants Kerberos 5 support | 3020 | # Check whether user wants Kerberos 5 support |
3004 | KRB5_MSG="no" | 3021 | KRB5_MSG="no" |
3005 | AC_ARG_WITH(kerberos5, | 3022 | AC_ARG_WITH(kerberos5, |
@@ -3818,6 +3835,7 @@ fi | |||
3818 | echo " Manpage format: $MANTYPE" | 3835 | echo " Manpage format: $MANTYPE" |
3819 | echo " PAM support: $PAM_MSG" | 3836 | echo " PAM support: $PAM_MSG" |
3820 | echo " KerberosV support: $KRB5_MSG" | 3837 | echo " KerberosV support: $KRB5_MSG" |
3838 | echo " SELinux support: $SELINUX_MSG" | ||
3821 | echo " Smartcard support: $SCARD_MSG" | 3839 | echo " Smartcard support: $SCARD_MSG" |
3822 | echo " S/KEY support: $SKEY_MSG" | 3840 | echo " S/KEY support: $SKEY_MSG" |
3823 | echo " TCP Wrappers support: $TCPW_MSG" | 3841 | echo " TCP Wrappers support: $TCPW_MSG" |