summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 460383757..d98e6f74a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -676,6 +676,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
676 [Use tunnel device compatibility to OpenBSD]) 676 [Use tunnel device compatibility to OpenBSD])
677 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 677 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
678 [Prepend the address family to IP tunnel traffic]) 678 [Prepend the address family to IP tunnel traffic])
679 AC_MSG_CHECKING([if we have the Security Authorization Session API])
680 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
681 [SessionCreate(0, 0);],
682 [ac_cv_use_security_session_api="yes"
683 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
684 [platform has the Security Authorization Session API])
685 LIBS="$LIBS -framework Security"
686 AC_MSG_RESULT([yes])],
687 [ac_cv_use_security_session_api="no"
688 AC_MSG_RESULT([no])])
689 AC_MSG_CHECKING([if we have an in-memory credentials cache])
690 AC_TRY_COMPILE(
691 [#include <Kerberos/Kerberos.h>],
692 [cc_context_t c;
693 (void) cc_initialize (&c, 0, NULL, NULL);],
694 [AC_DEFINE([USE_CCAPI], [1],
695 [platform uses an in-memory credentials cache])
696 LIBS="$LIBS -framework Security"
697 AC_MSG_RESULT([yes])
698 if test "x$ac_cv_use_security_session_api" = "xno"; then
699 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
700 fi],
701 [AC_MSG_RESULT([no])]
702 )
679 m4_pattern_allow([AU_IPv]) 703 m4_pattern_allow([AU_IPv])
680 AC_CHECK_DECL([AU_IPv4], [], 704 AC_CHECK_DECL([AU_IPv4], [],
681 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 705 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])