diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 30be6c182..2869f7042 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -665,6 +665,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
665 | [Use tunnel device compatibility to OpenBSD]) | 665 | [Use tunnel device compatibility to OpenBSD]) |
666 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], | 666 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], |
667 | [Prepend the address family to IP tunnel traffic]) | 667 | [Prepend the address family to IP tunnel traffic]) |
668 | AC_MSG_CHECKING([if we have the Security Authorization Session API]) | ||
669 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
670 | [SessionCreate(0, 0);], | ||
671 | [ac_cv_use_security_session_api="yes" | ||
672 | AC_DEFINE([USE_SECURITY_SESSION_API], [1], | ||
673 | [platform has the Security Authorization Session API]) | ||
674 | LIBS="$LIBS -framework Security" | ||
675 | AC_MSG_RESULT([yes])], | ||
676 | [ac_cv_use_security_session_api="no" | ||
677 | AC_MSG_RESULT([no])]) | ||
678 | AC_MSG_CHECKING([if we have an in-memory credentials cache]) | ||
679 | AC_TRY_COMPILE( | ||
680 | [#include <Kerberos/Kerberos.h>], | ||
681 | [cc_context_t c; | ||
682 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
683 | [AC_DEFINE([USE_CCAPI], [1], | ||
684 | [platform uses an in-memory credentials cache]) | ||
685 | LIBS="$LIBS -framework Security" | ||
686 | AC_MSG_RESULT([yes]) | ||
687 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
688 | AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***]) | ||
689 | fi], | ||
690 | [AC_MSG_RESULT([no])] | ||
691 | ) | ||
668 | m4_pattern_allow([AU_IPv]) | 692 | m4_pattern_allow([AU_IPv]) |
669 | AC_CHECK_DECL([AU_IPv4], [], | 693 | AC_CHECK_DECL([AU_IPv4], [], |
670 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) | 694 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) |