summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d98e6f74a..812b7218f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1558,6 +1558,62 @@ else
1558 AC_MSG_RESULT([no]) 1558 AC_MSG_RESULT([no])
1559fi 1559fi
1560 1560
1561# Check whether user wants TCP wrappers support
1562TCPW_MSG="no"
1563AC_ARG_WITH([tcp-wrappers],
1564 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1565 [
1566 if test "x$withval" != "xno" ; then
1567 saved_LIBS="$LIBS"
1568 saved_LDFLAGS="$LDFLAGS"
1569 saved_CPPFLAGS="$CPPFLAGS"
1570 if test -n "${withval}" && \
1571 test "x${withval}" != "xyes"; then
1572 if test -d "${withval}/lib"; then
1573 if test -n "${need_dash_r}"; then
1574 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1575 else
1576 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1577 fi
1578 else
1579 if test -n "${need_dash_r}"; then
1580 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1581 else
1582 LDFLAGS="-L${withval} ${LDFLAGS}"
1583 fi
1584 fi
1585 if test -d "${withval}/include"; then
1586 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1587 else
1588 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1589 fi
1590 fi
1591 LIBS="-lwrap $LIBS"
1592 AC_MSG_CHECKING([for libwrap])
1593 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1594#include <sys/types.h>
1595#include <sys/socket.h>
1596#include <netinet/in.h>
1597#include <tcpd.h>
1598int deny_severity = 0, allow_severity = 0;
1599 ]], [[
1600 hosts_access(0);
1601 ]])], [
1602 AC_MSG_RESULT([yes])
1603 AC_DEFINE([LIBWRAP], [1],
1604 [Define if you want
1605 TCP Wrappers support])
1606 SSHDLIBS="$SSHDLIBS -lwrap"
1607 TCPW_MSG="yes"
1608 ], [
1609 AC_MSG_ERROR([*** libwrap missing])
1610
1611 ])
1612 LIBS="$saved_LIBS"
1613 fi
1614 ]
1615)
1616
1561# Check whether user wants to use ldns 1617# Check whether user wants to use ldns
1562LDNS_MSG="no" 1618LDNS_MSG="no"
1563AC_ARG_WITH(ldns, 1619AC_ARG_WITH(ldns,
@@ -5479,6 +5535,7 @@ echo " PAM support: $PAM_MSG"
5479echo " OSF SIA support: $SIA_MSG" 5535echo " OSF SIA support: $SIA_MSG"
5480echo " KerberosV support: $KRB5_MSG" 5536echo " KerberosV support: $KRB5_MSG"
5481echo " SELinux support: $SELINUX_MSG" 5537echo " SELinux support: $SELINUX_MSG"
5538echo " TCP Wrappers support: $TCPW_MSG"
5482echo " MD5 password support: $MD5_MSG" 5539echo " MD5 password support: $MD5_MSG"
5483echo " libedit support: $LIBEDIT_MSG" 5540echo " libedit support: $LIBEDIT_MSG"
5484echo " libldns support: $LDNS_MSG" 5541echo " libldns support: $LDNS_MSG"