summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 19 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index f7ce777a5..cd6acaf9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,7 @@ AC_PROG_CPP
30AC_PROG_RANLIB 30AC_PROG_RANLIB
31AC_PROG_INSTALL 31AC_PROG_INSTALL
32AC_PROG_EGREP 32AC_PROG_EGREP
33AC_PATH_PROG([AR], [ar]) 33AC_CHECK_TOOLS([AR], [ar])
34AC_PATH_PROG([CAT], [cat]) 34AC_PATH_PROG([CAT], [cat])
35AC_PATH_PROG([KILL], [kill]) 35AC_PATH_PROG([KILL], [kill])
36AC_PATH_PROGS([PERL], [perl5 perl]) 36AC_PATH_PROGS([PERL], [perl5 perl])
@@ -140,12 +140,17 @@ else
140fi 140fi
141 141
142AC_ARG_WITH([ssh1], 142AC_ARG_WITH([ssh1],
143 [ --without-ssh1 Disable support for SSH protocol 1], 143 [ --without-ssh1 Enable support for SSH protocol 1],
144 [ 144 [
145 if test "x$withval" = "xno" ; then 145 if test "x$withval" = "xyes" ; then
146 if test "x$openssl" = "xno" ; then
147 AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled])
148 fi
149 ssh1=yes
150 elif test "x$withval" = "xno" ; then
146 ssh1=no 151 ssh1=no
147 elif test "x$openssl" = "xno" ; then 152 else
148 AC_MSG_ERROR([Cannot enable SSH protocol 1 with OpenSSL disabled]) 153 AC_MSG_ERROR([unknown --with-ssh1 argument])
149 fi 154 fi
150 ] 155 ]
151) 156)
@@ -800,14 +805,17 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
800 i*86-*) 805 i*86-*)
801 seccomp_audit_arch=AUDIT_ARCH_I386 806 seccomp_audit_arch=AUDIT_ARCH_I386
802 ;; 807 ;;
803 arm*-*) 808 arm*-*)
804 seccomp_audit_arch=AUDIT_ARCH_ARM 809 seccomp_audit_arch=AUDIT_ARCH_ARM
805 ;; 810 ;;
811 aarch64*-*)
812 seccomp_audit_arch=AUDIT_ARCH_AARCH64
813 ;;
806 esac 814 esac
807 if test "x$seccomp_audit_arch" != "x" ; then 815 if test "x$seccomp_audit_arch" != "x" ; then
808 AC_MSG_RESULT(["$seccomp_audit_arch"]) 816 AC_MSG_RESULT(["$seccomp_audit_arch"])
809 AC_DEFINE_UNQUOTED([SECCOMP_AUDIT_ARCH], [$seccomp_audit_arch], 817 AC_DEFINE_UNQUOTED([SECCOMP_AUDIT_ARCH], [$seccomp_audit_arch],
810 [Specify the system call convention in use]) 818 [Specify the system call convention in use])
811 else 819 else
812 AC_MSG_RESULT([architecture not supported]) 820 AC_MSG_RESULT([architecture not supported])
813 fi 821 fi
@@ -4455,7 +4463,7 @@ if test ! -z "$IPADDR_IN_DISPLAY" ; then
4455else 4463else
4456 DISPLAY_HACK_MSG="no" 4464 DISPLAY_HACK_MSG="no"
4457 AC_ARG_WITH([ipaddr-display], 4465 AC_ARG_WITH([ipaddr-display],
4458 [ --with-ipaddr-display Use ip address instead of hostname in \$DISPLAY], 4466 [ --with-ipaddr-display Use ip address instead of hostname in $DISPLAY],
4459 [ 4467 [
4460 if test "x$withval" != "xno" ; then 4468 if test "x$withval" != "xno" ; then
4461 AC_DEFINE([IPADDR_IN_DISPLAY]) 4469 AC_DEFINE([IPADDR_IN_DISPLAY])
@@ -4501,7 +4509,7 @@ fi
4501# Whether to mess with the default path 4509# Whether to mess with the default path
4502SERVER_PATH_MSG="(default)" 4510SERVER_PATH_MSG="(default)"
4503AC_ARG_WITH([default-path], 4511AC_ARG_WITH([default-path],
4504 [ --with-default-path= Specify default \$PATH environment for server], 4512 [ --with-default-path= Specify default $PATH environment for server],
4505 [ 4513 [
4506 if test "x$external_path_file" = "x/etc/login.conf" ; then 4514 if test "x$external_path_file" = "x/etc/login.conf" ; then
4507 AC_MSG_WARN([ 4515 AC_MSG_WARN([