summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4a1b50331..4c1a6589e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -548,6 +548,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
548 [Use tunnel device compatibility to OpenBSD]) 548 [Use tunnel device compatibility to OpenBSD])
549 AC_DEFINE([SSH_TUN_PREPEND_AF], [1], 549 AC_DEFINE([SSH_TUN_PREPEND_AF], [1],
550 [Prepend the address family to IP tunnel traffic]) 550 [Prepend the address family to IP tunnel traffic])
551 AC_MSG_CHECKING([if we have the Security Authorization Session API])
552 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
553 [SessionCreate(0, 0);],
554 [ac_cv_use_security_session_api="yes"
555 AC_DEFINE([USE_SECURITY_SESSION_API], [1],
556 [platform has the Security Authorization Session API])
557 LIBS="$LIBS -framework Security"
558 AC_MSG_RESULT([yes])],
559 [ac_cv_use_security_session_api="no"
560 AC_MSG_RESULT([no])])
561 AC_MSG_CHECKING([if we have an in-memory credentials cache])
562 AC_TRY_COMPILE(
563 [#include <Kerberos/Kerberos.h>],
564 [cc_context_t c;
565 (void) cc_initialize (&c, 0, NULL, NULL);],
566 [AC_DEFINE([USE_CCAPI], [1],
567 [platform uses an in-memory credentials cache])
568 LIBS="$LIBS -framework Security"
569 AC_MSG_RESULT([yes])
570 if test "x$ac_cv_use_security_session_api" = "xno"; then
571 AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***])
572 fi],
573 [AC_MSG_RESULT([no])]
574 )
551 m4_pattern_allow([AU_IPv]) 575 m4_pattern_allow([AU_IPv])
552 AC_CHECK_DECL([AU_IPv4], [], 576 AC_CHECK_DECL([AU_IPv4], [],
553 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) 577 AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records])