summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ecfa50c4b..c596a7bd9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.369 2006/10/03 16:34:35 tim Exp $ 1# $Id: configure.ac,v 1.370 2006/10/06 23:07:21 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org) 17AC_INIT(OpenSSH, Portable, openssh-unix-dev@mindrot.org)
18AC_REVISION($Revision: 1.369 $) 18AC_REVISION($Revision: 1.370 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20 20
21AC_CONFIG_HEADER(config.h) 21AC_CONFIG_HEADER(config.h)
@@ -3145,7 +3145,10 @@ AC_ARG_WITH(selinux,
3145 AC_MSG_ERROR(SELinux support requires selinux.h header)) 3145 AC_MSG_ERROR(SELinux support requires selinux.h header))
3146 AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ], 3146 AC_CHECK_LIB(selinux, setexeccon, [ LIBSELINUX="-lselinux" ],
3147 AC_MSG_ERROR(SELinux support requires libselinux library)) 3147 AC_MSG_ERROR(SELinux support requires libselinux library))
3148 save_LIBS="$LIBS"
3149 LIBS="$LIBS $LIBSELINUX"
3148 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level) 3150 AC_CHECK_FUNCS(getseuserbyname get_default_context_with_level)
3151 LIBS="$save_LIBS"
3149 fi ] 3152 fi ]
3150) 3153)
3151AC_SUBST(LIBSELINUX) 3154AC_SUBST(LIBSELINUX)