diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 39 |
1 files changed, 33 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac index c70c504f9..d35a19bcc 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.526 2013/06/01 20:28:04 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.527 2013/06/01 21:18:48 dtucker Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -15,7 +15,7 @@ | |||
15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. | 15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. |
16 | 16 | ||
17 | AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) | 17 | AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) |
18 | AC_REVISION($Revision: 1.526 $) | 18 | AC_REVISION($Revision: 1.527 $) |
19 | AC_CONFIG_SRCDIR([ssh.c]) | 19 | AC_CONFIG_SRCDIR([ssh.c]) |
20 | AC_LANG([C]) | 20 | AC_LANG([C]) |
21 | 21 | ||
@@ -979,9 +979,6 @@ mips-sony-bsd|mips-sony-newsos4) | |||
979 | *-*-nto-qnx*) | 979 | *-*-nto-qnx*) |
980 | AC_DEFINE([USE_PIPES]) | 980 | AC_DEFINE([USE_PIPES]) |
981 | AC_DEFINE([NO_X11_UNIX_SOCKETS]) | 981 | AC_DEFINE([NO_X11_UNIX_SOCKETS]) |
982 | AC_DEFINE([MISSING_NFDBITS], [1], [Define on *nto-qnx systems]) | ||
983 | AC_DEFINE([MISSING_HOWMANY], [1], [Define on *nto-qnx systems]) | ||
984 | AC_DEFINE([MISSING_FD_MASK], [1], [Define on *nto-qnx systems]) | ||
985 | AC_DEFINE([DISABLE_LASTLOG]) | 982 | AC_DEFINE([DISABLE_LASTLOG]) |
986 | AC_DEFINE([SSHD_ACQUIRES_CTTY]) | 983 | AC_DEFINE([SSHD_ACQUIRES_CTTY]) |
987 | AC_DEFINE([BROKEN_SHADOW_EXPIRE], [1], [QNX shadow support is broken]) | 984 | AC_DEFINE([BROKEN_SHADOW_EXPIRE], [1], [QNX shadow support is broken]) |
@@ -1002,7 +999,6 @@ mips-sony-bsd|mips-sony-newsos4) | |||
1002 | 999 | ||
1003 | *-*-lynxos) | 1000 | *-*-lynxos) |
1004 | CFLAGS="$CFLAGS -D__NO_INCLUDE_WARN__" | 1001 | CFLAGS="$CFLAGS -D__NO_INCLUDE_WARN__" |
1005 | AC_DEFINE([MISSING_HOWMANY]) | ||
1006 | AC_DEFINE([BROKEN_SETVBUF], [1], [LynxOS has broken setvbuf() implementation]) | 1002 | AC_DEFINE([BROKEN_SETVBUF], [1], [LynxOS has broken setvbuf() implementation]) |
1007 | ;; | 1003 | ;; |
1008 | esac | 1004 | esac |
@@ -1703,6 +1699,37 @@ AC_CHECK_DECLS([offsetof], , , [ | |||
1703 | #include <stddef.h> | 1699 | #include <stddef.h> |
1704 | ]) | 1700 | ]) |
1705 | 1701 | ||
1702 | # extra bits for select(2) | ||
1703 | AC_CHECK_DECLS([howmany, NFDBITS], [], [], [[ | ||
1704 | #include <sys/param.h> | ||
1705 | #include <sys/types.h> | ||
1706 | #ifdef HAVE_SYS_SYSMACROS_H | ||
1707 | #include <sys/sysmacros.h> | ||
1708 | #endif | ||
1709 | #ifdef HAVE_SYS_SELECT_H | ||
1710 | #include <sys/select.h> | ||
1711 | #endif | ||
1712 | #ifdef HAVE_SYS_TIME_H | ||
1713 | #include <sys/time.h> | ||
1714 | #endif | ||
1715 | #ifdef HAVE_UNISTD_H | ||
1716 | #include <unistd.h> | ||
1717 | #endif | ||
1718 | ]]) | ||
1719 | AC_CHECK_TYPES([fd_mask], [], [], [[ | ||
1720 | #include <sys/param.h> | ||
1721 | #include <sys/types.h> | ||
1722 | #ifdef HAVE_SYS_SELECT_H | ||
1723 | #include <sys/select.h> | ||
1724 | #endif | ||
1725 | #ifdef HAVE_SYS_TIME_H | ||
1726 | #include <sys/time.h> | ||
1727 | #endif | ||
1728 | #ifdef HAVE_UNISTD_H | ||
1729 | #include <unistd.h> | ||
1730 | #endif | ||
1731 | ]]) | ||
1732 | |||
1706 | AC_CHECK_FUNCS([setresuid], [ | 1733 | AC_CHECK_FUNCS([setresuid], [ |
1707 | dnl Some platorms have setresuid that isn't implemented, test for this | 1734 | dnl Some platorms have setresuid that isn't implemented, test for this |
1708 | AC_MSG_CHECKING([if setresuid seems to work]) | 1735 | AC_MSG_CHECKING([if setresuid seems to work]) |