diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index dfd32cd85..90eebf5fd 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -584,6 +584,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
584 | [Use tunnel device compatibility to OpenBSD]) | 584 | [Use tunnel device compatibility to OpenBSD]) |
585 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], | 585 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], |
586 | [Prepend the address family to IP tunnel traffic]) | 586 | [Prepend the address family to IP tunnel traffic]) |
587 | AC_MSG_CHECKING([if we have the Security Authorization Session API]) | ||
588 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
589 | [SessionCreate(0, 0);], | ||
590 | [ac_cv_use_security_session_api="yes" | ||
591 | AC_DEFINE([USE_SECURITY_SESSION_API], [1], | ||
592 | [platform has the Security Authorization Session API]) | ||
593 | LIBS="$LIBS -framework Security" | ||
594 | AC_MSG_RESULT([yes])], | ||
595 | [ac_cv_use_security_session_api="no" | ||
596 | AC_MSG_RESULT([no])]) | ||
597 | AC_MSG_CHECKING([if we have an in-memory credentials cache]) | ||
598 | AC_TRY_COMPILE( | ||
599 | [#include <Kerberos/Kerberos.h>], | ||
600 | [cc_context_t c; | ||
601 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
602 | [AC_DEFINE([USE_CCAPI], [1], | ||
603 | [platform uses an in-memory credentials cache]) | ||
604 | LIBS="$LIBS -framework Security" | ||
605 | AC_MSG_RESULT([yes]) | ||
606 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
607 | AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***]) | ||
608 | fi], | ||
609 | [AC_MSG_RESULT([no])] | ||
610 | ) | ||
587 | m4_pattern_allow([AU_IPv]) | 611 | m4_pattern_allow([AU_IPv]) |
588 | AC_CHECK_DECL([AU_IPv4], [], | 612 | AC_CHECK_DECL([AU_IPv4], [], |
589 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) | 613 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) |