diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 13 |
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac index fd8218aea..58a3ff47d 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.261 2005/05/26 10:12:15 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.262 2005/05/26 10:48:25 djm Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -79,6 +79,15 @@ AC_SUBST(LD) | |||
79 | AC_C_INLINE | 79 | AC_C_INLINE |
80 | if test "$GCC" = "yes" || test "$GCC" = "egcs"; then | 80 | if test "$GCC" = "yes" || test "$GCC" = "egcs"; then |
81 | CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wno-uninitialized" | 81 | CFLAGS="$CFLAGS -Wall -Wpointer-arith -Wno-uninitialized" |
82 | |||
83 | # Check for -std=gnu99 support (needed for LLONG_MIN/MAX on Linux) | ||
84 | saved_CFLAGS="$CFLAGS" | ||
85 | CFLAGS="$CFLAGS -std=gnu99" | ||
86 | AC_MSG_CHECKING(whether cc accepts -std=gnu99 option) | ||
87 | AC_TRY_COMPILE([], [return(0);], [AC_MSG_RESULT(yes)], | ||
88 | [AC_MSG_RESULT(no) | ||
89 | CFLAGS="$saved_CFLAGS"], | ||
90 | ) | ||
82 | fi | 91 | fi |
83 | 92 | ||
84 | AC_ARG_WITH(rpath, | 93 | AC_ARG_WITH(rpath, |
@@ -922,7 +931,7 @@ AC_CHECK_FUNCS(\ | |||
922 | setdtablesize setegid setenv seteuid setgroups setlogin setpcred \ | 931 | setdtablesize setegid setenv seteuid setgroups setlogin setpcred \ |
923 | setproctitle setregid setreuid setrlimit \ | 932 | setproctitle setregid setreuid setrlimit \ |
924 | setsid setvbuf sigaction sigvec snprintf socketpair strerror \ | 933 | setsid setvbuf sigaction sigvec snprintf socketpair strerror \ |
925 | strlcat strlcpy strmode strnvis strtoul sysconf tcgetpgrp \ | 934 | strlcat strlcpy strmode strnvis strtonum strtoul sysconf tcgetpgrp \ |
926 | truncate unsetenv updwtmpx utimes vhangup vsnprintf waitpid \ | 935 | truncate unsetenv updwtmpx utimes vhangup vsnprintf waitpid \ |
927 | ) | 936 | ) |
928 | 937 | ||