diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 19 |
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac index 9cc7dc97c..966f81265 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | i# $Id: configure.ac,v 1.11 2002/01/22 10:57:54 djm Exp $ | 1 | i# $Id: configure.ac,v 1.12 2002/01/22 11:16:05 djm Exp $ |
2 | 2 | ||
3 | AC_INIT | 3 | AC_INIT |
4 | AC_CONFIG_SRCDIR([ssh.c]) | 4 | AC_CONFIG_SRCDIR([ssh.c]) |
@@ -812,6 +812,23 @@ else | |||
812 | fi | 812 | fi |
813 | fi | 813 | fi |
814 | 814 | ||
815 | # Sanity check OpenSSL headers | ||
816 | AC_MSG_CHECKING([whether OpenSSL's headers match the library]) | ||
817 | AC_TRY_RUN( | ||
818 | [ | ||
819 | #include <string.h> | ||
820 | #include <openssl/opensslv.h> | ||
821 | int main(void) { return(SSLeay() == OPENSSL_VERSION_NUMBER ? 0 : 1); } | ||
822 | ], | ||
823 | [ | ||
824 | AC_MSG_RESULT(yes) | ||
825 | ], | ||
826 | [ | ||
827 | AC_MSG_RESULT(no) | ||
828 | AC_MSG_ERROR(Your OpenSSL headers do not match your library) | ||
829 | ] | ||
830 | ) | ||
831 | |||
815 | # Some Linux systems (Slackware) need crypt() from libcrypt, *not* the | 832 | # Some Linux systems (Slackware) need crypt() from libcrypt, *not* the |
816 | # version in OpenSSL. Skip this for PAM | 833 | # version in OpenSSL. Skip this for PAM |
817 | if test "x$PAM_MSG" = "xno" -a "x$check_for_libcrypt_later" = "x1"; then | 834 | if test "x$PAM_MSG" = "xno" -a "x$check_for_libcrypt_later" = "x1"; then |