diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 18 |
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac index 736f65027..00ca0fb5b 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -1,4 +1,4 @@ | |||
1 | # $Id: configure.ac,v 1.559 2014/01/23 12:14:40 dtucker Exp $ | 1 | # $Id: configure.ac,v 1.560 2014/01/25 01:34:39 djm Exp $ |
2 | # | 2 | # |
3 | # Copyright (c) 1999-2004 Damien Miller | 3 | # Copyright (c) 1999-2004 Damien Miller |
4 | # | 4 | # |
@@ -15,7 +15,7 @@ | |||
15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. | 15 | # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. |
16 | 16 | ||
17 | AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) | 17 | AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) |
18 | AC_REVISION($Revision: 1.559 $) | 18 | AC_REVISION($Revision: 1.560 $) |
19 | AC_CONFIG_SRCDIR([ssh.c]) | 19 | AC_CONFIG_SRCDIR([ssh.c]) |
20 | AC_LANG([C]) | 20 | AC_LANG([C]) |
21 | 21 | ||
@@ -3032,6 +3032,13 @@ elif test "x$sandbox_arg" = "xseccomp_filter" || \ | |||
3032 | AC_MSG_ERROR([seccomp_filter sandbox requires prctl function]) | 3032 | AC_MSG_ERROR([seccomp_filter sandbox requires prctl function]) |
3033 | SANDBOX_STYLE="seccomp_filter" | 3033 | SANDBOX_STYLE="seccomp_filter" |
3034 | AC_DEFINE([SANDBOX_SECCOMP_FILTER], [1], [Sandbox using seccomp filter]) | 3034 | AC_DEFINE([SANDBOX_SECCOMP_FILTER], [1], [Sandbox using seccomp filter]) |
3035 | elif test "x$sandbox_arg" = "xcapsicum" || \ | ||
3036 | ( test -z "$sandbox_arg" && \ | ||
3037 | test "x$have_cap_enter" = "x1") ; then | ||
3038 | test "x$have_cap_enter" != "x1" && \ | ||
3039 | AC_MSG_ERROR([capsicum sandbox requires cap_enter function]) | ||
3040 | SANDBOX_STYLE="capsicum" | ||
3041 | AC_DEFINE([SANDBOX_CAPSICUM], [1], [Sandbox using capsicum]) | ||
3035 | elif test "x$sandbox_arg" = "xrlimit" || \ | 3042 | elif test "x$sandbox_arg" = "xrlimit" || \ |
3036 | ( test -z "$sandbox_arg" && test "x$ac_cv_func_setrlimit" = "xyes" && \ | 3043 | ( test -z "$sandbox_arg" && test "x$ac_cv_func_setrlimit" = "xyes" && \ |
3037 | test "x$select_works_with_rlimit" = "xyes" && \ | 3044 | test "x$select_works_with_rlimit" = "xyes" && \ |
@@ -3042,13 +3049,6 @@ elif test "x$sandbox_arg" = "xrlimit" || \ | |||
3042 | AC_MSG_ERROR([rlimit sandbox requires select to work with rlimit]) | 3049 | AC_MSG_ERROR([rlimit sandbox requires select to work with rlimit]) |
3043 | SANDBOX_STYLE="rlimit" | 3050 | SANDBOX_STYLE="rlimit" |
3044 | AC_DEFINE([SANDBOX_RLIMIT], [1], [Sandbox using setrlimit(2)]) | 3051 | AC_DEFINE([SANDBOX_RLIMIT], [1], [Sandbox using setrlimit(2)]) |
3045 | elif test "x$sandbox_arg" = "xcapsicum" || \ | ||
3046 | ( test -z "$sandbox_arg" && \ | ||
3047 | test "x$have_cap_enter" = "x1") ; then | ||
3048 | test "x$have_cap_enter" != "x1" && \ | ||
3049 | AC_MSG_ERROR([capsicum sandbox requires cap_enter function]) | ||
3050 | SANDBOX_STYLE="capsicum" | ||
3051 | AC_DEFINE([SANDBOX_CAPSICUM], [1], [Sandbox using capsicum]) | ||
3052 | elif test -z "$sandbox_arg" || test "x$sandbox_arg" = "xno" || \ | 3052 | elif test -z "$sandbox_arg" || test "x$sandbox_arg" = "xno" || \ |
3053 | test "x$sandbox_arg" = "xnone" || test "x$sandbox_arg" = "xnull" ; then | 3053 | test "x$sandbox_arg" = "xnone" || test "x$sandbox_arg" = "xnull" ; then |
3054 | SANDBOX_STYLE="none" | 3054 | SANDBOX_STYLE="none" |