summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 812b7218f..7e0584d2c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4730,6 +4730,29 @@ AC_ARG_WITH([kerberos5],
4730AC_SUBST([GSSLIBS]) 4730AC_SUBST([GSSLIBS])
4731AC_SUBST([K5LIBS]) 4731AC_SUBST([K5LIBS])
4732 4732
4733# Check whether user wants systemd support
4734SYSTEMD_MSG="no"
4735AC_ARG_WITH(systemd,
4736 [ --with-systemd Enable systemd support],
4737 [ if test "x$withval" != "xno" ; then
4738 AC_PATH_TOOL([PKGCONFIG], [pkg-config], [no])
4739 if test "$PKGCONFIG" != "no"; then
4740 AC_MSG_CHECKING([for libsystemd])
4741 if $PKGCONFIG --exists libsystemd; then
4742 SYSTEMD_CFLAGS=`$PKGCONFIG --cflags libsystemd`
4743 SYSTEMD_LIBS=`$PKGCONFIG --libs libsystemd`
4744 CPPFLAGS="$CPPFLAGS $SYSTEMD_CFLAGS"
4745 SSHDLIBS="$SSHDLIBS $SYSTEMD_LIBS"
4746 AC_MSG_RESULT([yes])
4747 AC_DEFINE(HAVE_SYSTEMD, 1, [Define if you want systemd support.])
4748 SYSTEMD_MSG="yes"
4749 else
4750 AC_MSG_RESULT([no])
4751 fi
4752 fi
4753 fi ]
4754)
4755
4733# Looking for programs, paths and files 4756# Looking for programs, paths and files
4734 4757
4735PRIVSEP_PATH=/var/empty 4758PRIVSEP_PATH=/var/empty
@@ -5542,6 +5565,7 @@ echo " libldns support: $LDNS_MSG"
5542echo " Solaris process contract support: $SPC_MSG" 5565echo " Solaris process contract support: $SPC_MSG"
5543echo " Solaris project support: $SP_MSG" 5566echo " Solaris project support: $SP_MSG"
5544echo " Solaris privilege support: $SPP_MSG" 5567echo " Solaris privilege support: $SPP_MSG"
5568echo " systemd support: $SYSTEMD_MSG"
5545echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 5569echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
5546echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 5570echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
5547echo " BSD Auth support: $BSD_AUTH_MSG" 5571echo " BSD Auth support: $BSD_AUTH_MSG"