summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b8f970074..f60bbdd27 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.232 2004/11/02 09:30:54 dtucker Exp $ 1# $Id: configure.ac,v 1.233 2004/11/07 09:14:34 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -854,6 +854,22 @@ AC_ARG_WITH(tcp-wrappers,
854 ] 854 ]
855) 855)
856 856
857# Check whether user wants libedit support
858LIBEDIT_MSG="no"
859AC_ARG_WITH(libedit,
860 [ --with-libedit[[=PATH]] Enable libedit support for sftp],
861 [ if test "x$withval" != "xno" ; then
862 AC_CHECK_LIB(edit, el_init,
863 [ AC_DEFINE(USE_LIBEDIT, [], [Use libedit for sftp])
864 LIBEDIT="-ledit -lcurses"
865 LIBEDIT_MSG="yes"
866 AC_SUBST(LIBEDIT)
867 ],
868 [], [-lcurses]
869 )
870 fi ]
871)
872
857dnl Checks for library functions. Please keep in alphabetical order 873dnl Checks for library functions. Please keep in alphabetical order
858AC_CHECK_FUNCS(\ 874AC_CHECK_FUNCS(\
859 arc4random __b64_ntop b64_ntop __b64_pton b64_pton bcopy \ 875 arc4random __b64_ntop b64_ntop __b64_pton b64_pton bcopy \
@@ -3046,6 +3062,7 @@ echo " Smartcard support: $SCARD_MSG"
3046echo " S/KEY support: $SKEY_MSG" 3062echo " S/KEY support: $SKEY_MSG"
3047echo " TCP Wrappers support: $TCPW_MSG" 3063echo " TCP Wrappers support: $TCPW_MSG"
3048echo " MD5 password support: $MD5_MSG" 3064echo " MD5 password support: $MD5_MSG"
3065echo " libedit support: $LIBEDIT_MSG"
3049echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG" 3066echo " IP address in \$DISPLAY hack: $DISPLAY_HACK_MSG"
3050echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG" 3067echo " Translate v4 in v6 hack: $IPV4_IN6_HACK_MSG"
3051echo " BSD Auth support: $BSD_AUTH_MSG" 3068echo " BSD Auth support: $BSD_AUTH_MSG"