summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8b32e40c9..64c231b7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.498 2012/12/03 01:35:55 djm Exp $ 1# $Id: configure.ac,v 1.499 2012/12/12 21:18:56 djm Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.498 $) 18AC_REVISION($Revision: 1.499 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -2299,6 +2299,27 @@ AC_LINK_IFELSE(
2299 ] 2299 ]
2300) 2300)
2301 2301
2302# Check for OpenSSL with EVP_aes_*ctr
2303AC_MSG_CHECKING([whether OpenSSL has AES CTR via EVP])
2304AC_LINK_IFELSE(
2305 [AC_LANG_PROGRAM([[
2306#include <string.h>
2307#include <openssl/evp.h>
2308 ]], [[
2309 exit(EVP_aes_128_ctr() == NULL ||
2310 EVP_aes_192_cbc() == NULL ||
2311 EVP_aes_256_cbc() == NULL);
2312 ]])],
2313 [
2314 AC_MSG_RESULT([yes])
2315 AC_DEFINE([OPENSSL_HAVE_EVPCTR], [1],
2316 [libcrypto has EVP AES CTR])
2317 ],
2318 [
2319 AC_MSG_RESULT([no])
2320 ]
2321)
2322
2302AC_MSG_CHECKING([if EVP_DigestUpdate returns an int]) 2323AC_MSG_CHECKING([if EVP_DigestUpdate returns an int])
2303AC_LINK_IFELSE( 2324AC_LINK_IFELSE(
2304 [AC_LANG_PROGRAM([[ 2325 [AC_LANG_PROGRAM([[