summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index efafb6bd8..cee7cbc51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1556,6 +1556,62 @@ else
1556 AC_MSG_RESULT([no]) 1556 AC_MSG_RESULT([no])
1557fi 1557fi
1558 1558
1559# Check whether user wants TCP wrappers support
1560TCPW_MSG="no"
1561AC_ARG_WITH([tcp-wrappers],
1562 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1563 [
1564 if test "x$withval" != "xno" ; then
1565 saved_LIBS="$LIBS"
1566 saved_LDFLAGS="$LDFLAGS"
1567 saved_CPPFLAGS="$CPPFLAGS"
1568 if test -n "${withval}" && \
1569 test "x${withval}" != "xyes"; then
1570 if test -d "${withval}/lib"; then
1571 if test -n "${need_dash_r}"; then
1572 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1573 else
1574 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1575 fi
1576 else
1577 if test -n "${need_dash_r}"; then
1578 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1579 else
1580 LDFLAGS="-L${withval} ${LDFLAGS}"
1581 fi
1582 fi
1583 if test -d "${withval}/include"; then
1584 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1585 else
1586 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1587 fi
1588 fi
1589 LIBS="-lwrap $LIBS"
1590 AC_MSG_CHECKING([for libwrap])
1591 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1592#include <sys/types.h>
1593#include <sys/socket.h>
1594#include <netinet/in.h>
1595#include <tcpd.h>
1596int deny_severity = 0, allow_severity = 0;
1597 ]], [[
1598 hosts_access(0);
1599 ]])], [
1600 AC_MSG_RESULT([yes])
1601 AC_DEFINE([LIBWRAP], [1],
1602 [Define if you want
1603 TCP Wrappers support])
1604 SSHDLIBS="$SSHDLIBS -lwrap"
1605 TCPW_MSG="yes"
1606 ], [
1607 AC_MSG_ERROR([*** libwrap missing])
1608
1609 ])
1610 LIBS="$saved_LIBS"
1611 fi
1612 ]
1613)
1614
1559# Check whether user wants to use ldns 1615# Check whether user wants to use ldns
1560LDNS_MSG="no" 1616LDNS_MSG="no"
1561AC_ARG_WITH(ldns, 1617AC_ARG_WITH(ldns,
@@ -5413,6 +5469,7 @@ echo " PAM support: $PAM_MSG"
5413echo " OSF SIA support: $SIA_MSG" 5469echo " OSF SIA support: $SIA_MSG"
5414echo " KerberosV support: $KRB5_MSG" 5470echo " KerberosV support: $KRB5_MSG"
5415echo " SELinux support: $SELINUX_MSG" 5471echo " SELinux support: $SELINUX_MSG"
5472echo " TCP Wrappers support: $TCPW_MSG"
5416echo " MD5 password support: $MD5_MSG" 5473echo " MD5 password support: $MD5_MSG"
5417echo " libedit support: $LIBEDIT_MSG" 5474echo " libedit support: $LIBEDIT_MSG"
5418echo " libldns support: $LDNS_MSG" 5475echo " libldns support: $LDNS_MSG"