diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 88dd29e9d..271a63a46 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -533,6 +533,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
533 | [Use tunnel device compatibility to OpenBSD]) | 533 | [Use tunnel device compatibility to OpenBSD]) |
534 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], | 534 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], |
535 | [Prepend the address family to IP tunnel traffic]) | 535 | [Prepend the address family to IP tunnel traffic]) |
536 | AC_MSG_CHECKING([if we have the Security Authorization Session API]) | ||
537 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
538 | [SessionCreate(0, 0);], | ||
539 | [ac_cv_use_security_session_api="yes" | ||
540 | AC_DEFINE([USE_SECURITY_SESSION_API], [1], | ||
541 | [platform has the Security Authorization Session API]) | ||
542 | LIBS="$LIBS -framework Security" | ||
543 | AC_MSG_RESULT([yes])], | ||
544 | [ac_cv_use_security_session_api="no" | ||
545 | AC_MSG_RESULT([no])]) | ||
546 | AC_MSG_CHECKING([if we have an in-memory credentials cache]) | ||
547 | AC_TRY_COMPILE( | ||
548 | [#include <Kerberos/Kerberos.h>], | ||
549 | [cc_context_t c; | ||
550 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
551 | [AC_DEFINE([USE_CCAPI], [1], | ||
552 | [platform uses an in-memory credentials cache]) | ||
553 | LIBS="$LIBS -framework Security" | ||
554 | AC_MSG_RESULT([yes]) | ||
555 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
556 | AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***]) | ||
557 | fi], | ||
558 | [AC_MSG_RESULT([no])] | ||
559 | ) | ||
536 | m4_pattern_allow([AU_IPv]) | 560 | m4_pattern_allow([AU_IPv]) |
537 | AC_CHECK_DECL([AU_IPv4], [], | 561 | AC_CHECK_DECL([AU_IPv4], [], |
538 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) | 562 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) |