diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac index 7258cc0e5..5f1ff740f 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -632,6 +632,30 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16)) | |||
632 | [Use tunnel device compatibility to OpenBSD]) | 632 | [Use tunnel device compatibility to OpenBSD]) |
633 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], | 633 | AC_DEFINE([SSH_TUN_PREPEND_AF], [1], |
634 | [Prepend the address family to IP tunnel traffic]) | 634 | [Prepend the address family to IP tunnel traffic]) |
635 | AC_MSG_CHECKING([if we have the Security Authorization Session API]) | ||
636 | AC_TRY_COMPILE([#include <Security/AuthSession.h>], | ||
637 | [SessionCreate(0, 0);], | ||
638 | [ac_cv_use_security_session_api="yes" | ||
639 | AC_DEFINE([USE_SECURITY_SESSION_API], [1], | ||
640 | [platform has the Security Authorization Session API]) | ||
641 | LIBS="$LIBS -framework Security" | ||
642 | AC_MSG_RESULT([yes])], | ||
643 | [ac_cv_use_security_session_api="no" | ||
644 | AC_MSG_RESULT([no])]) | ||
645 | AC_MSG_CHECKING([if we have an in-memory credentials cache]) | ||
646 | AC_TRY_COMPILE( | ||
647 | [#include <Kerberos/Kerberos.h>], | ||
648 | [cc_context_t c; | ||
649 | (void) cc_initialize (&c, 0, NULL, NULL);], | ||
650 | [AC_DEFINE([USE_CCAPI], [1], | ||
651 | [platform uses an in-memory credentials cache]) | ||
652 | LIBS="$LIBS -framework Security" | ||
653 | AC_MSG_RESULT([yes]) | ||
654 | if test "x$ac_cv_use_security_session_api" = "xno"; then | ||
655 | AC_MSG_ERROR([*** Need a security framework to use the credentials cache API ***]) | ||
656 | fi], | ||
657 | [AC_MSG_RESULT([no])] | ||
658 | ) | ||
635 | m4_pattern_allow([AU_IPv]) | 659 | m4_pattern_allow([AU_IPv]) |
636 | AC_CHECK_DECL([AU_IPv4], [], | 660 | AC_CHECK_DECL([AU_IPv4], [], |
637 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) | 661 | AC_DEFINE([AU_IPv4], [0], [System only supports IPv4 audit records]) |