summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 68586a30d..76a603d29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -819,6 +819,27 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
819 ]) 819 ])
820 AC_CHECK_HEADERS([linux/seccomp.h linux/filter.h linux/audit.h], [], 820 AC_CHECK_HEADERS([linux/seccomp.h linux/filter.h linux/audit.h], [],
821 [], [#include <linux/types.h>]) 821 [], [#include <linux/types.h>])
822 # Obtain MIPS ABI
823 case "$host" in
824 mips*)
825 AC_COMPILE_IFELSE([
826#if _MIPS_SIM != _ABIO32
827#error
828#endif
829 ],[mips_abi="o32"],[AC_COMPILE_IFELSE([
830#if _MIPS_SIM != _ABIN32
831#error
832#endif
833 ],[mips_abi="n32"],[AC_COMPILE_IFELSE([
834#if _MIPS_SIM != _ABI64
835#error
836#endif
837 ],[mips_abi="n64"],[AC_MSG_ERROR([unknown MIPS ABI])
838 ])
839 ])
840 ])
841 ;;
842 esac
822 AC_MSG_CHECKING([for seccomp architecture]) 843 AC_MSG_CHECKING([for seccomp architecture])
823 seccomp_audit_arch= 844 seccomp_audit_arch=
824 case "$host" in 845 case "$host" in