summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index d6c57864c..b8a610d5c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.530 2013/06/02 16:03:26 dtucker Exp $ 1# $Id: configure.ac,v 1.531 2013/06/02 21:05:49 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -15,7 +15,7 @@
15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. 15# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
16 16
17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org]) 17AC_INIT([OpenSSH], [Portable], [openssh-unix-dev@mindrot.org])
18AC_REVISION($Revision: 1.530 $) 18AC_REVISION($Revision: 1.531 $)
19AC_CONFIG_SRCDIR([ssh.c]) 19AC_CONFIG_SRCDIR([ssh.c])
20AC_LANG([C]) 20AC_LANG([C])
21 21
@@ -812,6 +812,7 @@ mips-sony-bsd|mips-sony-newsos4)
812 SP_MSG="yes" ], ) 812 SP_MSG="yes" ], )
813 ], 813 ],
814 ) 814 )
815 TEST_SHELL=$SHELL # let configure find us a capable shell
815 ;; 816 ;;
816*-*-sunos4*) 817*-*-sunos4*)
817 CPPFLAGS="$CPPFLAGS -DSUNOS4" 818 CPPFLAGS="$CPPFLAGS -DSUNOS4"
@@ -855,6 +856,7 @@ mips-sony-bsd|mips-sony-newsos4)
855 AC_DEFINE([BROKEN_SETREGID]) 856 AC_DEFINE([BROKEN_SETREGID])
856 AC_DEFINE([PASSWD_NEEDS_USERNAME], [1], [must supply username to passwd]) 857 AC_DEFINE([PASSWD_NEEDS_USERNAME], [1], [must supply username to passwd])
857 AC_DEFINE([LOCKED_PASSWD_STRING], ["*LK*"]) 858 AC_DEFINE([LOCKED_PASSWD_STRING], ["*LK*"])
859 TEST_SHELL=$SHELL # let configure find us a capable shell
858 ;; 860 ;;
859# UnixWare 7.x, OpenUNIX 8 861# UnixWare 7.x, OpenUNIX 8
860*-*-sysv5*) 862*-*-sysv5*)
@@ -866,10 +868,10 @@ mips-sony-bsd|mips-sony-newsos4)
866 AC_DEFINE([BROKEN_SETREUID]) 868 AC_DEFINE([BROKEN_SETREUID])
867 AC_DEFINE([BROKEN_SETREGID]) 869 AC_DEFINE([BROKEN_SETREGID])
868 AC_DEFINE([PASSWD_NEEDS_USERNAME]) 870 AC_DEFINE([PASSWD_NEEDS_USERNAME])
871 TEST_SHELL=$SHELL # let configure find us a capable shell
869 case "$host" in 872 case "$host" in
870 *-*-sysv5SCO_SV*) # SCO OpenServer 6.x 873 *-*-sysv5SCO_SV*) # SCO OpenServer 6.x
871 maildir=/var/spool/mail 874 maildir=/var/spool/mail
872 TEST_SHELL=/u95/bin/sh
873 AC_DEFINE([BROKEN_LIBIAF], [1], 875 AC_DEFINE([BROKEN_LIBIAF], [1],
874 [ia_uinfo routines not supported by OS yet]) 876 [ia_uinfo routines not supported by OS yet])
875 AC_DEFINE([BROKEN_UPDWTMPX]) 877 AC_DEFINE([BROKEN_UPDWTMPX])
@@ -910,7 +912,7 @@ mips-sony-bsd|mips-sony-newsos4)
910 AC_DEFINE([PASSWD_NEEDS_USERNAME]) 912 AC_DEFINE([PASSWD_NEEDS_USERNAME])
911 AC_CHECK_FUNCS([getluid setluid]) 913 AC_CHECK_FUNCS([getluid setluid])
912 MANTYPE=man 914 MANTYPE=man
913 TEST_SHELL=ksh 915 TEST_SHELL=$SHELL # let configure find us a capable shell
914 SKIP_DISABLE_LASTLOG_DEFINE=yes 916 SKIP_DISABLE_LASTLOG_DEFINE=yes
915 ;; 917 ;;
916*-*-unicosmk*) 918*-*-unicosmk*)