summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 82428b241..ebc10f51e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1526,6 +1526,62 @@ else
1526 AC_MSG_RESULT([no]) 1526 AC_MSG_RESULT([no])
1527fi 1527fi
1528 1528
1529# Check whether user wants TCP wrappers support
1530TCPW_MSG="no"
1531AC_ARG_WITH([tcp-wrappers],
1532 [ --with-tcp-wrappers[[=PATH]] Enable tcpwrappers support (optionally in PATH)],
1533 [
1534 if test "x$withval" != "xno" ; then
1535 saved_LIBS="$LIBS"
1536 saved_LDFLAGS="$LDFLAGS"
1537 saved_CPPFLAGS="$CPPFLAGS"
1538 if test -n "${withval}" && \
1539 test "x${withval}" != "xyes"; then
1540 if test -d "${withval}/lib"; then
1541 if test -n "${need_dash_r}"; then
1542 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
1543 else
1544 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
1545 fi
1546 else
1547 if test -n "${need_dash_r}"; then
1548 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
1549 else
1550 LDFLAGS="-L${withval} ${LDFLAGS}"
1551 fi
1552 fi
1553 if test -d "${withval}/include"; then
1554 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
1555 else
1556 CPPFLAGS="-I${withval} ${CPPFLAGS}"
1557 fi
1558 fi
1559 LIBS="-lwrap $LIBS"
1560 AC_MSG_CHECKING([for libwrap])
1561 AC_LINK_IFELSE([AC_LANG_PROGRAM([[
1562#include <sys/types.h>
1563#include <sys/socket.h>
1564#include <netinet/in.h>
1565#include <tcpd.h>
1566int deny_severity = 0, allow_severity = 0;
1567 ]], [[
1568 hosts_access(0);
1569 ]])], [
1570 AC_MSG_RESULT([yes])
1571 AC_DEFINE([LIBWRAP], [1],
1572 [Define if you want
1573 TCP Wrappers support])
1574 SSHDLIBS="$SSHDLIBS -lwrap"
1575 TCPW_MSG="yes"
1576 ], [
1577 AC_MSG_ERROR([*** libwrap missing])
1578
1579 ])
1580 LIBS="$saved_LIBS"
1581 fi
1582 ]
1583)
1584
1529# Check whether user wants to use ldns 1585# Check whether user wants to use ldns
1530LDNS_MSG="no" 1586LDNS_MSG="no"
1531AC_ARG_WITH(ldns, 1587AC_ARG_WITH(ldns,
@@ -5201,6 +5257,7 @@ echo " PAM support: $PAM_MSG"
5201echo " OSF SIA support: $SIA_MSG" 5257echo " OSF SIA support: $SIA_MSG"
5202echo " KerberosV support: $KRB5_MSG" 5258echo " KerberosV support: $KRB5_MSG"
5203echo " SELinux support: $SELINUX_MSG" 5259echo " SELinux support: $SELINUX_MSG"
5260echo " TCP Wrappers support: $TCPW_MSG"
5204echo " MD5 password support: $MD5_MSG" 5261echo " MD5 password support: $MD5_MSG"
5205echo " libedit support: $LIBEDIT_MSG" 5262echo " libedit support: $LIBEDIT_MSG"
5206echo " libldns support: $LDNS_MSG" 5263echo " libldns support: $LDNS_MSG"