summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 9dce893a1..d77138505 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.254 2005/03/18 00:52:21 tim Exp $ 1# $Id: configure.ac,v 1.255 2005/03/20 22:55:17 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -587,10 +587,9 @@ AC_SEARCH_LIBS(basename, gen, AC_DEFINE(HAVE_BASENAME))
587dnl zlib is required 587dnl zlib is required
588AC_ARG_WITH(zlib, 588AC_ARG_WITH(zlib,
589 [ --with-zlib=PATH Use zlib in PATH], 589 [ --with-zlib=PATH Use zlib in PATH],
590 [ 590 [ if test "x$withval" = "xno" ; then
591 if test "x$withval" = "xno" ; then 591 AC_MSG_ERROR([*** zlib is required ***])
592 AC_MSG_ERROR([*** zlib is required ***]) 592 elif test "x$withval" != "xyes"; then
593 fi
594 if test -d "$withval/lib"; then 593 if test -d "$withval/lib"; then
595 if test -n "${need_dash_r}"; then 594 if test -n "${need_dash_r}"; then
596 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}" 595 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
@@ -609,7 +608,7 @@ AC_ARG_WITH(zlib,
609 else 608 else
610 CPPFLAGS="-I${withval} ${CPPFLAGS}" 609 CPPFLAGS="-I${withval} ${CPPFLAGS}"
611 fi 610 fi
612 ] 611 fi ]
613) 612)
614 613
615AC_CHECK_LIB(z, deflate, , 614AC_CHECK_LIB(z, deflate, ,