summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 13 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index c23094777..ca41ecc77 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.251 2005/03/17 21:37:04 tim Exp $ 1# $Id: configure.ac,v 1.252 2005/03/18 00:23:19 tim Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -794,7 +794,8 @@ AC_ARG_WITH(tcp-wrappers,
794 saved_LIBS="$LIBS" 794 saved_LIBS="$LIBS"
795 saved_LDFLAGS="$LDFLAGS" 795 saved_LDFLAGS="$LDFLAGS"
796 saved_CPPFLAGS="$CPPFLAGS" 796 saved_CPPFLAGS="$CPPFLAGS"
797 if test -n "${withval}" -a "${withval}" != "yes"; then 797 if test -n "${withval}" && \
798 test "${withval}" != "yes"; then
798 if test -d "${withval}/lib"; then 799 if test -d "${withval}/lib"; then
799 if test -n "${need_dash_r}"; then 800 if test -n "${need_dash_r}"; then
800 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}" 801 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
@@ -1090,7 +1091,8 @@ main()
1090 ) 1091 )
1091fi 1092fi
1092 1093
1093if test "x$ac_cv_func_getaddrinfo" = "xyes" -a "x$check_for_hpux_broken_getaddrinfo" = "x1"; then 1094if test "x$ac_cv_func_getaddrinfo" = "xyes" && \
1095 test "x$check_for_hpux_broken_getaddrinfo" = "x1"; then
1094 AC_MSG_CHECKING(if getaddrinfo seems to work) 1096 AC_MSG_CHECKING(if getaddrinfo seems to work)
1095 AC_TRY_RUN( 1097 AC_TRY_RUN(
1096 [ 1098 [
@@ -1158,7 +1160,8 @@ main(void)
1158 ) 1160 )
1159fi 1161fi
1160 1162
1161if test "x$ac_cv_func_getaddrinfo" = "xyes" -a "x$check_for_aix_broken_getaddrinfo" = "x1"; then 1163if test "x$ac_cv_func_getaddrinfo" = "xyes" && \
1164 test "x$check_for_aix_broken_getaddrinfo" = "x1"; then
1162 AC_MSG_CHECKING(if getaddrinfo seems to work) 1165 AC_MSG_CHECKING(if getaddrinfo seems to work)
1163 AC_TRY_RUN( 1166 AC_TRY_RUN(
1164 [ 1167 [
@@ -1492,7 +1495,7 @@ AC_ARG_WITH(rand-helper,
1492) 1495)
1493 1496
1494# Which randomness source do we use? 1497# Which randomness source do we use?
1495if test ! -z "$OPENSSL_SEEDS_ITSELF" -a -z "$USE_RAND_HELPER" ; then 1498if test ! -z "$OPENSSL_SEEDS_ITSELF" && test -z "$USE_RAND_HELPER" ; then
1496 # OpenSSL only 1499 # OpenSSL only
1497 AC_DEFINE(OPENSSL_PRNG_ONLY) 1500 AC_DEFINE(OPENSSL_PRNG_ONLY)
1498 RAND_MSG="OpenSSL internal ONLY" 1501 RAND_MSG="OpenSSL internal ONLY"
@@ -2030,9 +2033,9 @@ fi
2030AC_CHECK_TYPES(struct timespec) 2033AC_CHECK_TYPES(struct timespec)
2031 2034
2032# We need int64_t or else certian parts of the compile will fail. 2035# We need int64_t or else certian parts of the compile will fail.
2033if test "x$ac_cv_have_int64_t" = "xno" -a \ 2036if test "x$ac_cv_have_int64_t" = "xno" && \
2034 "x$ac_cv_sizeof_long_int" != "x8" -a \ 2037 test "x$ac_cv_sizeof_long_int" != "x8" && \
2035 "x$ac_cv_sizeof_long_long_int" = "x0" ; then 2038 test "x$ac_cv_sizeof_long_long_int" = "x0" ; then
2036 echo "OpenSSH requires int64_t support. Contact your vendor or install" 2039 echo "OpenSSH requires int64_t support. Contact your vendor or install"
2037 echo "an alternative compiler (I.E., GCC) before continuing." 2040 echo "an alternative compiler (I.E., GCC) before continuing."
2038 echo "" 2041 echo ""
@@ -2682,8 +2685,8 @@ if test "x$etc_default_login" != "xno"; then
2682fi 2685fi
2683 2686
2684dnl BSD systems use /etc/login.conf so --with-default-path= has no effect 2687dnl BSD systems use /etc/login.conf so --with-default-path= has no effect
2685if test $ac_cv_func_login_getcapbool = "yes" -a \ 2688if test $ac_cv_func_login_getcapbool = "yes" && \
2686 $ac_cv_header_login_cap_h = "yes" ; then 2689 test $ac_cv_header_login_cap_h = "yes" ; then
2687 external_path_file=/etc/login.conf 2690 external_path_file=/etc/login.conf
2688fi 2691fi
2689 2692