summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d900df4b5..1693cfae8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -854,6 +854,7 @@ mips-sony-bsd|mips-sony-newsos4)
854 AC_DEFINE([SYSLOG_R_SAFE_IN_SIGHAND], [1], 854 AC_DEFINE([SYSLOG_R_SAFE_IN_SIGHAND], [1],
855 [syslog_r function is safe to use in in a signal handler]) 855 [syslog_r function is safe to use in in a signal handler])
856 TEST_MALLOC_OPTIONS="AFGJPRX" 856 TEST_MALLOC_OPTIONS="AFGJPRX"
857 AC_CHECK_FUNCS([tame])
857 ;; 858 ;;
858*-*-solaris*) 859*-*-solaris*)
859 if test "x$withval" != "xno" ; then 860 if test "x$withval" != "xno" ; then
@@ -2997,7 +2998,7 @@ fi
2997# Decide which sandbox style to use 2998# Decide which sandbox style to use
2998sandbox_arg="" 2999sandbox_arg=""
2999AC_ARG_WITH([sandbox], 3000AC_ARG_WITH([sandbox],
3000 [ --with-sandbox=style Specify privilege separation sandbox (no, darwin, rlimit, systrace, seccomp_filter, capsicum)], 3001 [ --with-sandbox=style Specify privilege separation sandbox (no, capsicum, darwin, rlimit, seccomp_filter, systrace, tame)],
3001 [ 3002 [
3002 if test "x$withval" = "xyes" ; then 3003 if test "x$withval" = "xyes" ; then
3003 sandbox_arg="" 3004 sandbox_arg=""
@@ -3093,7 +3094,13 @@ AC_RUN_IFELSE(
3093 [AC_MSG_WARN([cross compiling: assuming yes])] 3094 [AC_MSG_WARN([cross compiling: assuming yes])]
3094) 3095)
3095 3096
3096if test "x$sandbox_arg" = "xsystrace" || \ 3097if test "x$sandbox_arg" = "xtame" || \
3098 ( test -z "$sandbox_arg" && test "x$ac_cv_func_tame" = "xyes" ) ; then
3099 test "x$ac_cv_func_tame" != "xyes" && \
3100 AC_MSG_ERROR([tame sandbox requires tame(2) support])
3101 SANDBOX_STYLE="tame"
3102 AC_DEFINE([SANDBOX_TAME], [1], [Sandbox using tame(2)])
3103elif test "x$sandbox_arg" = "xsystrace" || \
3097 ( test -z "$sandbox_arg" && test "x$have_systr_policy_kill" = "x1" ) ; then 3104 ( test -z "$sandbox_arg" && test "x$have_systr_policy_kill" = "x1" ) ; then
3098 test "x$have_systr_policy_kill" != "x1" && \ 3105 test "x$have_systr_policy_kill" != "x1" && \
3099 AC_MSG_ERROR([systrace sandbox requires systrace headers and SYSTR_POLICY_KILL support]) 3106 AC_MSG_ERROR([systrace sandbox requires systrace headers and SYSTR_POLICY_KILL support])