summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ec0274e70..0ed1ddddf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1i# $Id: configure.ac,v 1.9 2002/01/05 23:24:28 stevesk Exp $ 1i# $Id: configure.ac,v 1.10 2002/01/14 08:01:06 djm Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -1538,6 +1538,12 @@ AC_ARG_WITH(random,
1538 [ 1538 [
1539 if test "x$withval" != "xno" ; then 1539 if test "x$withval" != "xno" ; then
1540 RANDOM_POOL="$withval"; 1540 RANDOM_POOL="$withval";
1541 if ! echo "$RANDOM_POOL" | grep -q '^/' ; then
1542 AC_MSG_ERROR(You must specify an absolute path to the random device)
1543 fi
1544 if ! test -r "$RANDOM_POOL" ; then
1545 AC_MSG_WARN(Random device is not readable)
1546 fi
1541 AC_DEFINE_UNQUOTED(RANDOM_POOL, "$RANDOM_POOL") 1547 AC_DEFINE_UNQUOTED(RANDOM_POOL, "$RANDOM_POOL")
1542 fi 1548 fi
1543 ], 1549 ],
@@ -1570,6 +1576,12 @@ AC_ARG_WITH(prngd-socket,
1570 [ 1576 [
1571 if test "x$withval" != "xno" ; then 1577 if test "x$withval" != "xno" ; then
1572 PRNGD_SOCKET="$withval" 1578 PRNGD_SOCKET="$withval"
1579 if echo "$PRNGD_SOCKET" | grep -q '^/' ; then
1580 AC_MSG_ERROR(You must specify an absolute path to the entropy socket)
1581 fi
1582 if ! test -r "$PRNGD_SOCKET" ; then
1583 AC_MSG_WARN(Entropy socket is not readable)
1584 fi
1573 AC_DEFINE_UNQUOTED(PRNGD_SOCKET, "$PRNGD_SOCKET") 1585 AC_DEFINE_UNQUOTED(PRNGD_SOCKET, "$PRNGD_SOCKET")
1574 fi 1586 fi
1575 ], 1587 ],