summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e8bee9d4e..b8f970074 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.231 2004/09/30 11:17:08 dtucker Exp $ 1# $Id: configure.ac,v 1.232 2004/11/02 09:30:54 dtucker Exp $
2# 2#
3# Copyright (c) 1999-2004 Damien Miller 3# Copyright (c) 1999-2004 Damien Miller
4# 4#
@@ -220,6 +220,7 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
220 AC_DEFINE(LOCKED_PASSWD_STRING, "*") 220 AC_DEFINE(LOCKED_PASSWD_STRING, "*")
221 AC_DEFINE(SPT_TYPE,SPT_PSTAT) 221 AC_DEFINE(SPT_TYPE,SPT_PSTAT)
222 check_for_hpux_broken_getaddrinfo=1 222 check_for_hpux_broken_getaddrinfo=1
223 check_for_conflicting_getspnam=1
223 LIBS="$LIBS -lsec" 224 LIBS="$LIBS -lsec"
224 AC_CHECK_LIB(xnet, t_error, ,AC_MSG_ERROR([*** -lxnet needed on HP-UX - check config.log ***])) 225 AC_CHECK_LIB(xnet, t_error, ,AC_MSG_ERROR([*** -lxnet needed on HP-UX - check config.log ***]))
225 ;; 226 ;;
@@ -1123,6 +1124,24 @@ main(void)
1123 ) 1124 )
1124fi 1125fi
1125 1126
1127if test "x$check_for_conflicting_getspnam" = "x1"; then
1128 AC_MSG_CHECKING(for conflicting getspnam in shadow.h)
1129 AC_COMPILE_IFELSE(
1130 [
1131#include <shadow.h>
1132int main(void) {exit(0);}
1133 ],
1134 [
1135 AC_MSG_RESULT(no)
1136 ],
1137 [
1138 AC_MSG_RESULT(yes)
1139 AC_DEFINE(GETSPNAM_CONFLICTING_DEFS, 1,
1140 [Conflicting defs for getspnam])
1141 ]
1142 )
1143fi
1144
1126AC_FUNC_GETPGRP 1145AC_FUNC_GETPGRP
1127 1146
1128# Check for PAM libs 1147# Check for PAM libs