summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 33 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a2b236355..05ccc2f7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -403,7 +403,31 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
403 [Use tunnel device compatibility to OpenBSD]) 403 [Use tunnel device compatibility to OpenBSD])
404 AC_DEFINE(SSH_TUN_PREPEND_AF, 1, 404 AC_DEFINE(SSH_TUN_PREPEND_AF, 1,
405 [Prepend the address family to IP tunnel traffic]) 405 [Prepend the address family to IP tunnel traffic])
406 ;; 406 AC_MSG_CHECKING(if we have the Security Authorization Session API)
407 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
408 [SessionCreate(0, 0);],
409 [ac_cv_use_security_session_api="yes"
410 AC_DEFINE(USE_SECURITY_SESSION_API, 1,
411 [platform has the Security Authorization Session API])
412 LIBS="$LIBS -framework Security"
413 AC_MSG_RESULT(yes)],
414 [ac_cv_use_security_session_api="no"
415 AC_MSG_RESULT(no)])
416 AC_MSG_CHECKING(if we have an in-memory credentials cache)
417 AC_TRY_COMPILE(
418 [#include <Kerberos/Kerberos.h>],
419 [cc_context_t c;
420 (void) cc_initialize (&c, 0, NULL, NULL);],
421 [AC_DEFINE(USE_CCAPI, 1,
422 [platform uses an in-memory credentials cache])
423 LIBS="$LIBS -framework Security"
424 AC_MSG_RESULT(yes)
425 if test "x$ac_cv_use_security_session_api" = "xno"; then
426 AC_MSG_ERROR(*** Need a security framework to use the credentials cache API ***)
427 fi],
428 [AC_MSG_RESULT(no)]
429 )
430 ;;
407*-*-dragonfly*) 431*-*-dragonfly*)
408 SSHDLIBS="$SSHDLIBS -lcrypt" 432 SSHDLIBS="$SSHDLIBS -lcrypt"
409 ;; 433 ;;
@@ -486,6 +510,14 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
486 AC_DEFINE(WITH_ABBREV_NO_TTY) 510 AC_DEFINE(WITH_ABBREV_NO_TTY)
487 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") 511 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*")
488 ;; 512 ;;
513*-*-k*bsd*-gnu)
514 check_for_libcrypt_later=1
515 AC_DEFINE(PAM_TTY_KLUDGE)
516 AC_DEFINE(LOCKED_PASSWD_PREFIX, "!")
517 AC_DEFINE(SPT_TYPE,SPT_REUSEARGV)
518 AC_DEFINE(_PATH_BTMP, "/var/log/btmp", [log for bad login attempts])
519 AC_DEFINE(USE_BTMP, 1, [Use btmp to log bad logins])
520 ;;
489*-*-linux*) 521*-*-linux*)
490 no_dev_ptmx=1 522 no_dev_ptmx=1
491 check_for_libcrypt_later=1 523 check_for_libcrypt_later=1