summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 33 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f1052b079..64ef3c67b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -412,7 +412,31 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
412 [Use tunnel device compatibility to OpenBSD]) 412 [Use tunnel device compatibility to OpenBSD])
413 AC_DEFINE(SSH_TUN_PREPEND_AF, 1, 413 AC_DEFINE(SSH_TUN_PREPEND_AF, 1,
414 [Prepend the address family to IP tunnel traffic]) 414 [Prepend the address family to IP tunnel traffic])
415 ;; 415 AC_MSG_CHECKING(if we have the Security Authorization Session API)
416 AC_TRY_COMPILE([#include <Security/AuthSession.h>],
417 [SessionCreate(0, 0);],
418 [ac_cv_use_security_session_api="yes"
419 AC_DEFINE(USE_SECURITY_SESSION_API, 1,
420 [platform has the Security Authorization Session API])
421 LIBS="$LIBS -framework Security"
422 AC_MSG_RESULT(yes)],
423 [ac_cv_use_security_session_api="no"
424 AC_MSG_RESULT(no)])
425 AC_MSG_CHECKING(if we have an in-memory credentials cache)
426 AC_TRY_COMPILE(
427 [#include <Kerberos/Kerberos.h>],
428 [cc_context_t c;
429 (void) cc_initialize (&c, 0, NULL, NULL);],
430 [AC_DEFINE(USE_CCAPI, 1,
431 [platform uses an in-memory credentials cache])
432 LIBS="$LIBS -framework Security"
433 AC_MSG_RESULT(yes)
434 if test "x$ac_cv_use_security_session_api" = "xno"; then
435 AC_MSG_ERROR(*** Need a security framework to use the credentials cache API ***)
436 fi],
437 [AC_MSG_RESULT(no)]
438 )
439 ;;
416*-*-dragonfly*) 440*-*-dragonfly*)
417 SSHDLIBS="$SSHDLIBS -lcrypt" 441 SSHDLIBS="$SSHDLIBS -lcrypt"
418 ;; 442 ;;
@@ -495,6 +519,14 @@ main() { if (NSVersionOfRunTimeLibrary("System") >= (60 << 16))
495 AC_DEFINE(WITH_ABBREV_NO_TTY) 519 AC_DEFINE(WITH_ABBREV_NO_TTY)
496 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*") 520 AC_DEFINE(LOCKED_PASSWD_STRING, "*LK*")
497 ;; 521 ;;
522*-*-k*bsd*-gnu)
523 check_for_libcrypt_later=1
524 AC_DEFINE(PAM_TTY_KLUDGE)
525 AC_DEFINE(LOCKED_PASSWD_PREFIX, "!")
526 AC_DEFINE(SPT_TYPE,SPT_REUSEARGV)
527 AC_DEFINE(_PATH_BTMP, "/var/log/btmp", [log for bad login attempts])
528 AC_DEFINE(USE_BTMP, 1, [Use btmp to log bad logins])
529 ;;
498*-*-linux*) 530*-*-linux*)
499 no_dev_ptmx=1 531 no_dev_ptmx=1
500 check_for_libcrypt_later=1 532 check_for_libcrypt_later=1