summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac86
1 files changed, 2 insertions, 84 deletions
diff --git a/configure.ac b/configure.ac
index d86a2062d..ae2b6a7a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
1# $Id: configure.ac,v 1.5 2001/11/27 01:19:43 tim Exp $ 1# $Id: configure.ac,v 1.6 2001/12/07 17:20:48 mouring Exp $
2 2
3AC_INIT 3AC_INIT
4AC_CONFIG_SRCDIR([ssh.c]) 4AC_CONFIG_SRCDIR([ssh.c])
@@ -317,46 +317,6 @@ AC_ARG_WITH(libs,
317 ] 317 ]
318) 318)
319 319
320AC_ARG_WITH(pcre,
321 [ --with-pcre[[=PATH]] Override built in regex library with pcre
322 (optionally in PATH)],
323 [
324 case "$withval" in
325 no) ;;
326 *)
327 if test "x$withval" != "xyes"; then
328 if test -d "$withval/lib"; then
329 if test -n "${need_dash_r}"; then
330 LDFLAGS="-L${withval}/lib -R${withval}/lib ${LDFLAGS}"
331 else
332 LDFLAGS="-L${withval}/lib ${LDFLAGS}"
333 fi
334 else
335 if test -n "${need_dash_r}"; then
336 LDFLAGS="-L${withval} -R${withval} ${LDFLAGS}"
337 else
338 LDFLAGS="-L${withval} ${LDFLAGS}"
339 fi
340 fi
341 if test -d "$withval/include"; then
342 CPPFLAGS="-I${withval}/include ${CPPFLAGS}"
343 else
344 CPPFLAGS="-I${withval} ${CPPFLAGS}"
345 fi
346 fi
347
348 AC_CHECK_HEADER(pcreposix.h,
349 AC_CHECK_LIB(pcre, pcre_info,[
350 AC_DEFINE(HAVE_LIBPCRE)
351 LIBS="$LIBS -lpcreposix -lpcre"
352 no_comp_check=yes],
353 AC_MSG_ERROR([*** unable to locate pcre library ***])),
354 AC_MSG_ERROR([*** unable to locate pcreposix.h include file ***]))
355 ;;
356 esac
357 ]
358)
359
360# Checks for libraries. 320# Checks for libraries.
361AC_CHECK_FUNC(yp_match, , AC_CHECK_LIB(nsl, yp_match)) 321AC_CHECK_FUNC(yp_match, , AC_CHECK_LIB(nsl, yp_match))
362AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt)) 322AC_CHECK_FUNC(setsockopt, , AC_CHECK_LIB(socket, setsockopt))
@@ -398,48 +358,6 @@ AC_ARG_WITH(zlib,
398 358
399AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first or check config.log ***])) 359AC_CHECK_LIB(z, deflate, ,AC_MSG_ERROR([*** zlib missing - please install first or check config.log ***]))
400 360
401# We don't want to check if we did an pcre override.
402if test -z "$no_comp_check" ; then
403 AC_CHECK_FUNC(regcomp,
404 [
405 AC_CHECK_FUNC(regsub,
406 [
407 has_regcomp=no
408 ],
409 [
410 AC_DEFINE(HAVE_REGCOMP)
411 has_regcomp=yes
412 ]
413 )
414 ],
415 [
416 has_regcomp=no
417 ]
418 )
419 # Either regcomp wasn't defined or regsub is defined (which means
420 # that the libc regex is probably an old non-POSIX implementation.
421 # Now check for -lregex and -lpcreposix to find some usable regex
422 # implementation.
423 if test "$has_regcomp" = "no" ; then
424 AC_CHECK_LIB(regex, regcomp,
425 [
426 AC_DEFINE(HAVE_REGCOMP)
427 LIBS="$LIBS -lregex"
428 ],
429 [
430 AC_CHECK_LIB(pcre, pcre_info,
431 [
432 AC_DEFINE(HAVE_LIBPCRE)
433 LIBS="$LIBS -lpcreposix -lpcre"
434 ],
435 [
436 AC_MSG_ERROR([*** No regex library found.])
437 ])
438 ]
439 )
440 fi
441fi
442
443dnl UnixWare 2.x 361dnl UnixWare 2.x
444AC_CHECK_FUNC(strcasecmp, 362AC_CHECK_FUNC(strcasecmp,
445 [], [ AC_CHECK_LIB(resolv, strcasecmp, LIBS="$LIBS -lresolv") ] 363 [], [ AC_CHECK_LIB(resolv, strcasecmp, LIBS="$LIBS -lresolv") ]
@@ -459,7 +377,7 @@ AC_FUNC_STRFTIME
459AC_CHECK_HEADERS(bstring.h crypt.h endian.h floatingpoint.h \ 377AC_CHECK_HEADERS(bstring.h crypt.h endian.h floatingpoint.h \
460 getopt.h glob.h lastlog.h limits.h login.h \ 378 getopt.h glob.h lastlog.h limits.h login.h \
461 login_cap.h maillock.h netdb.h netgroup.h \ 379 login_cap.h maillock.h netdb.h netgroup.h \
462 netinet/in_systm.h paths.h poll.h pty.h regex.h \ 380 netinet/in_systm.h paths.h poll.h pty.h \
463 security/pam_appl.h shadow.h stddef.h stdint.h \ 381 security/pam_appl.h shadow.h stddef.h stdint.h \
464 strings.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h \ 382 strings.h sys/bitypes.h sys/bsdtty.h sys/cdefs.h \
465 sys/poll.h sys/queue.h sys/select.h sys/stat.h \ 383 sys/poll.h sys/queue.h sys/select.h sys/stat.h \